php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21224 apache configure fails when using --enable-versioning
Submitted: 2002-12-27 16:58 UTC Modified: 2003-02-25 05:23 UTC
Votes:9
Avg. Score:4.9 ± 0.3
Reproduced:9 of 9 (100.0%)
Same Version:9 (100.0%)
Same OS:0 (0.0%)
From: david at ols dot es Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.3.0 OS: Solaris 8
Private report: No CVE-ID:
 [2002-12-27 16:58 UTC] david at ols dot es
apache 1.3.27 configure script fails at this point:
with gcc version 2.95.2 and GNU ld version 2.13

 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed.  The below error output from the compilation
** test will give you an idea what is failing. Note that
** Apache requires an ANSI C Compiler, such as gcc.

======== Error Output for sanity check ========
make[1]: Entering directory `/usr/local/src/apache/apache_1.3.27/src/helpers'
cd ..; gcc -O3 -DDYNAMIC_MODULE_LIMIT=0 -I/usr/local/include/mysql  -DSOLARIS2=280 -DMOD_SSL=208111 -DEAPI -DUSE_EXPAT -I./lib/expat-lite -DNO_DL_NEEDED `./apaci`   -L/usr/local/ssl/lib  -o helpers/dummy helpers/dummy.c   -L/usr/local/lib/mysql -lmysqlclient   -R/usr/ucblib -R/opt/sfw/lib/gcc-lib/sparc-sun-solaris2.8/2.95.2 -R/usr/local/ssl/lib -R/usr/local/lib -R/opt/sfw/lib -R/usr/local/src/apache/imap-2002.RC5/c-client -R/usr/local/lib/mysql  -L/usr/ucblib -L/opt/sfw/lib/gcc-lib/sparc-sun-solaris2.8/2.95.2 -L/usr/local/ssl/lib -L/usr/local/lib -L/opt/sfw/lib -L/usr/local/src/apache/imap-2002.RC5/c-client -L/usr/local/lib/mysql -Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmodphp4 -export-symbols /usr/local/src/apache/php-4.3.0/sapi/apache/php.sym   -L/usr/ucblib -L/opt/sfw/lib/gcc-lib/sparc-sun-solaris2.8/2.95.2 -L/usr/local/ssl/lib -L/usr/local/lib -L/opt/sfw/lib -L/usr/local/src/apache/imap-2002.RC5/c-client -L/usr/local/lib/mysql  -lc-client  -lmm -lmysqlclient -lmcrypt -lltdl -lcrypt -lpam -lgd -lpng -lz -ljpeg -lgdbm -lcurl -lz -lcrypt -lssl -lcrypto -lresolv -lm -ldl -lnsl -lsocket  -lgcc -lcrypt -lcurl -ldl -lsocket -lnsl   -lsocket -lnsl -lpthread  -lssl -lcrypto
ld: fatal: file /usr/local/src/apache/php-4.3.0/sapi/apache/php.sym: unknown file type
ld: fatal: File processing errors. No output written to helpers/dummy
collect2: ld returned 1 exit status
make[1]: *** [dummy] Error 1
make[1]: Leaving directory `/usr/local/src/apache/apache_1.3.27/src/helpers'
============= End of Error Report =============

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-28 01:01 UTC] iliaa@php.net
What version of libtool are you using?
 [2002-12-28 04:33 UTC] david at ols dot es
the libtool on the php distribution tree is:

ltmain.sh (GNU libtool) 1.4.2 (1.922.2.53 2001/09/11 03:18:52)

I have to say that previous versions of php up to 4.3.0rc2
compiled fine on the same system.
 [2002-12-30 05:59 UTC] maddog2k at maddog2k dot nl
Same problem at Linux RedHat 6.2 machines, some with:
GNU ld 2.9.5
ltmain.sh (GNU libtool) 1.4.2 (1.922.2.53 2001/09/11 03:18:52) 

and others with:

GNU ld 2.13.2
ltmain.sh (GNU libtool) 1.4.3 (1.922.2.110 2002/10/23 01:39:54)
 [2002-12-30 09:32 UTC] chris at fast4gl dot com
I'm having the same problem building 4.3.0 with Apache on my server, 
previous builds were ok:

RedHat Linux 7.1 kernel 2.4.18-18.7.xsmp

gcc -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.2 2.96-112.7.1)

ld -v
GNU ld version 2.10.91 (with BFD 2.10.91.0.2)

libtool --version
ltmain.sh (GNU libtool) 1.3.5 (1.385.2.206 2000/05/27 11:12:27)

./configure --prefix=/usr/local/php \
--with-config-file-path=/usr/local/php --with-mysql=/usr/local/mysql \
--with-pgsql=/usr/local/pgsql --with-oci8=/usr/local/oracle \
--with-oracle=/usr/local/oracle --with-sybase-ct=/opt/sybase-12.5/OCS-12_5 \
--with-pdflib=/usr/local/pdflib --with-jpeg --with-tiff --with-zlib \
--with-gd --with-ttf --with-freetype --with-xml --with-gettext \
--enable-ftp --enable-versioning --enable-sockets --enable-calendar \
--enable-sysvsem --enable-sysvshm --enable-track-vars --enable-debugger \
--enable-magic-quotes --enable-rpath --enable-short-tags --enable-posix \
--enable-session --enable-xml --enable-bcmath --enable-ctype --enable-mailparse \
--with-apache=../apache_1.3.27 

./configure --with-layout=Apache --prefix=/usr/local/apache \
--activate-module=src/modules/php4/libphp4.a --enable-module=so \
--enable-module=rewrite --add-module=mod_gzip.c

Configuring for Apache, Version 1.3.27
 + using installation path layout: Apache (config.layout)
 + activated php4 module (modules/php4/libphp4.a)
 + on-the-fly added and activated gzip module (modules/extra/mod_gzip.o)
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for Linux platform
 + setting C compiler to gcc
 + setting C pre-processor to gcc -E
 + checking for system header files
 + adding selected modules
    o rewrite_module uses ConfigStart/End
 + using -lndbm for DBM support
      enabling DBM support for mod_rewrite
    o php4_module uses ConfigStart/End
 + using system Expat
 + using -ldl for vendor DSO support
 + checking sizeof various data types
 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed.  The below error output from the compilation
** test will give you an idea what is failing. Note that
** Apache requires an ANSI C Compiler, such as gcc. 

======== Error Output for sanity check ========
cd ..; gcc  -DLINUX=22 -I/usr/include/db1 `./apaci`     -o helpers/dummy helpers/dummy.c   -Wl,-rpath,/usr/local/mysql/lib/mysql -Wl,-rpath,/usr/local/oracle/lib -Wl,-rpath,/lib -Wl,-rpath,/usr/local/pdflib/lib -Wl,-rpath,/usr/local/pgsql/lib -Wl,-rpath,/opt/sybase-12.5/OCS-12_5/lib  -rdynamic -L/usr/local/mysql/lib/mysql -L/usr/local/oracle/lib -L/lib -L/usr/local/pdflib/lib -L/usr/local/pgsql/lib -L/opt/sybase-12.5/OCS-12_5/lib -Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmodphp4 -export-symbols /usr/local/src/php-4.3.0/sapi/apache/php.sym   -rdynamic -L/usr/local/mysql/lib/mysql -L/usr/local/oracle/lib -L/lib -L/usr/local/pdflib/lib -L/usr/local/pgsql/lib -L/opt/sybase-12.5/OCS-12_5/lib   -lsybtcl -lintl -lcomn -lct -lcs -lpq -lpdf -lz -lpng -lmysqlclient -lttf -lpng -lz -lz -lcrypt -lresolv -lm -ldl -lnsl  -lcrypt -ldl -lm -lnsl -lclntsh -ldl -lm -lnsl -lclntsh   -lm -lcrypt -lndbm -lexpat -ldl
/usr/bin/ld:/usr/local/src/php-4.3.0/sapi/apache/php.sym: file format not recognized; treating as linker script
/usr/bin/ld:/usr/local/src/php-4.3.0/sapi/apache/php.sym:2: parse error
collect2: ld returned 1 exit status
make: *** [dummy] Error 1
============= End of Error Report =============

 Aborting!
 [2003-01-06 05:02 UTC] wouter at widexs dot nl
Problem solved (for me) when removing --enable-versioning from the configure
 [2003-01-10 17:23 UTC] rayshell at nventure dot com
Same problem as everyone else.
ld: fatal: file /path/to/php-4.3.0/sapi/apache/php.sym  unknown file type.
Solaris8 and Solaris9.  GNU gcc 3.2.1
libtool 1.4, automake 1.7.2, autoconf 2.57
Apache 1.3.27.  However I will try not using
--enable-versioning and see if that works.  Because I did
use that in my configure.
 [2003-01-11 04:59 UTC] david at ols dot es
Problem solved when removing --enable-versioning from php configure settings
 [2003-01-15 13:36 UTC] pm at uaxnet dot se
Just little intressed.

Is anyone looking on this ???
I had the same problem on two servers. so I had to go back to 4.2.3

/Per
 [2003-02-25 05:23 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 01:01:59 2014 UTC