php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21220 Wrong Apache version in phpinfo() shown
Submitted: 2002-12-27 14:21 UTC Modified: 2003-09-09 17:43 UTC
Votes:2
Avg. Score:2.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: psychosos at gmx dot at Assigned:
Status: Closed Package: Apache related
PHP Version: 4.3.0 OS: Windows 2000 Professional
Private report: No CVE-ID:
 [2002-12-27 14:21 UTC] psychosos at gmx dot at
When executing a PHP script (*) on Apache 1.3.27 (PHP 4.3.0 as Apache module) it shows "Apache/1.3.24" as "Apache Version" while it should be 1.3.27.


(*) <?php phpinfo; ?>

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-27 15:55 UTC] edink@php.net
This is not a big. It simply shows the version of Apache php4apache.dll was compiled against. You can see you running apache version under SERVER_SOFTWARE.
 [2002-12-28 14:23 UTC] psychosos at gmx dot at
Well, I found change the name field then. Because if I read "Apache Version" to me it is obvious that the current Apache version running is meant. Specially if some lines below it says "Hostname:Port" and there I do not see the hostname of the machine where PHP was compiled but my own.

It's not really a bug, not serious or important in any way, it would just be cosmetic and I thought I could tell ;)

Regards,
johannes
 [2003-09-09 12:18 UTC] psychosos at gmx dot at
I still think this isn't completely bogus; I hope I explained my point of view understandable in the previous comment - if it says "Apache version" I think about the version of Apache, not about the version of the interface to Apache.
If you don't think it should be fixed that's ok, mark it bogus again and I'll keep my mouth shut :)
 [2003-09-09 17:43 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

Also added apache_get_version() function the same time.
(courtesy of Ilia A. :)

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 20:02:01 2014 UTC