php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21205 php4isapi.dll failed to load
Submitted: 2002-12-26 16:45 UTC Modified: 2002-12-26 16:48 UTC
From: wywong at pacbell dot net Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.3.0RC4 OS: Windows 2000 Advance Server
Private report: No CVE-ID: None
 [2002-12-26 16:45 UTC] wywong at pacbell dot net
This problem occurs in php-4.2.3 as well.  

Event Type:	Error
Event Source:	W3SVC
Event Category:	None
Event ID:	14
Date:		12/26/2002
Time:		2:42:39 PM
User:		N/A
Computer:	ROMBUS
Description:
The HTTP Filter DLL C:\php\sapi\php4isapi.dll failed to load.  The data is the error. 
For additional information specific to this message please visit the Microsoft Online Support site located at: http://www.microsoft.com/contentredirect.asp. 
Data:
0000: 7e 00 00 00               ~...    

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-26 16:48 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.
 [2002-12-26 18:10 UTC] wywong at pacbell dot net
Here is how I get it to work:

Copy C:\php\sapi\php4isapi.dll to C:\php

Stop IIS W3C service
Install to the default website:

Filter: PHP    Filter Path: C:\php\sapi\php4isapi.dll
Extension: .exe Path C:\php\sapi\php4isapi.dll

Start IIS W3C Service.

The up arrow of the Filter should be Green now.  If there is still a problem, reboot your machine.
 [2002-12-26 18:11 UTC] wywong at pacbell dot net
Oops.

Here is how I get it to work:

Copy C:\php\sapi\php4isapi.dll to C:\php

Stop IIS W3C service
Install to the default website:

Filter: PHP    Filter Path: C:\php\php4isapi.dll
Extension: .exe Path C:\php\php4isapi.dll

Start IIS W3C Service.

The up arrow of the Filter should be Green now.  If there is still a problem, reboot your machine.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 02:05:48 2023 UTC