php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21201 FDF Extension makes PHP crash
Submitted: 2002-12-26 11:19 UTC Modified: 2003-02-25 01:55 UTC
From: ermannov at netscape dot net Assigned:
Status: Not a bug Package: FDF related
PHP Version: 4.3.0RC4 OS: Windows 98 SE
Private report: No CVE-ID: None
 [2002-12-26 11:19 UTC] ermannov at netscape dot net
PHP crash if there is fdf extension loaded.
Commenting the extension in php.ini, it works.

List of extensions:
extension=php_cpdf.dll
extension=php_curl.dll
extension=php_dbg.dll
extension=php_dbx.dll
extension=php_domxml.dll
extension=php_exif.dll
;extension=php_fdf.dll
extension=php_gd.dll
extension=php_java.dll
extension=php_mhash.dll
extension=php_mime_magic.dll
extension=php_openssl.dll
extension=php_pdf.dll
extension=php_sockets.dll
extension=php_w32api.dll
extension=php_xmlrpc.dll
extension=php_xslt.dll
extension=php_zlib.dll

Dr. Watson dump:
PHP ha provocato un errore di pagina non valida nel
modulo PHP_FDF.DLL in 0177:01791220.
Registri:
EAX=00000091 CS=0177 EIP=01791220 EFLGS=00010246
EBX=007627f0 SS=017f ESP=0063fbd4 EBP=100ad170
ECX=007d4660 DS=017f ESI=007d1a60 FS=62df
EDX=00000000 ES=017f EDI=1012b460 GS=0000
Byte all'indirizzo CS:EIP:
c7 00 00 00 00 00 33 c0 c3 90 90 90 90 90 90 90 
Immagine dello stack:
100ad18d 00000001 00000015 007627f0 007d1ab0 100aa422 007d1a60 007627f0 
0063fc74 007627f0 0076384c 0063fc6c 100b6534 1012b460 100ad170 007627f0 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-26 12:02 UTC] philip@php.net
Duplicate of #14877

http://bugs.php.net/14877
 [2003-02-25 01:55 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.


http://bugs.php.net/14877


 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Sep 21 08:01:26 2019 UTC