php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21169 Compile Failure, and lots of warnings.
Submitted: 2002-12-23 19:32 UTC Modified: 2003-01-02 11:55 UTC
From: ler at lerctr dot org Assigned: derick
Status: Closed Package: Compile Failure
PHP Version: 4.3.0 OS: UnixWare 7.1.3
Private report: No CVE-ID:
 [2002-12-23 19:32 UTC] ler at lerctr dot org
UnixWare 7.1.3, Pentium 4, 1.70GHZ, 768Meg Ram.  
 
I can supply a test account.  
 
I'll attach the configure output and the compile output.  
 
Configure input: 
$ cat config.ler 
 CC="cc -Xb" CFLAGS="-O" ./configure  \ 
        --with-apxs=/usr/internet/apache/bin/apxs \ 
        --enable-safe-mode --enable-calendar --enable-ftp 
\ 
        --with-gd=/usr/local --with-pgsql=/usr/local/pgsql 
\ 
        --with-imap=/home/ler/SOURCE/imap/imap-2002a \ 
        --with-imap-ssl=/home/ler/SOURCE/imap/imap-2002a \ 
        --enable-shmop --enable-sysvsem --enable-sysvshm \ 
        --without-mysql --with-jpeg-dir=/usr/local \ 
        --with-ttf-dir=/usr/local 
--with-openssl=/usr/local/ssl \ 
        --with-zlib --enable-bcmath 
$ 
 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-23 19:35 UTC] ler at lerctr dot org
The make/configure output are here: 
 
http://www.lerctr.org/~ler/php/qa-out.txt 
 
The size is: 
$ ls -l qa* 
-rw-r--r--    1 ler      isis         211699 Dec 23 19:33 
qa-out.txt 
$ 
 
I can supply an account on request for this box.
 [2002-12-27 10:37 UTC] ler at lerctr dot org
I tried the 4.3.0 release tarball, and similar results.  
 
The make.out for it is at: 
 
http://www.lerctr.org/~ler/php/make.4.3.0.out.txt 
 
It's size is: 
 -rw-r--r--    1 ler      isis         183136 Dec 27 10:35 
make.4.3.0.out.txt 
 
 
My offer stands to give an account to ANY PHP team member 
to figure out what's going on here.
 [2003-01-02 08:23 UTC] derick@php.net
I found the cause of the problem (in mod_php4.c):

#undef shutdown 

which was added in revision 1.69 with commit message:

UnixWare defines shutdown to _shutdown, which causes problems lateron 
when using a structure member named shutdown. Since this sourcefile does 
not use the system call shutdown, it is safe to #undef it.PR: #6008, 
#6362 (those reports point to UnixWare 7.1.0).

The funny thing is that if I remove the "#undef shutdown" it compiles 
fine (except for this warning:

*** Warning: inter-library dependencies are not known to be supported.
*** All declared inter-library dependencies are being dropped.

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module libphp4.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.
)

I think it would be safe to remove the undef, but we will break 
something on Unixware 7.1.0 with that most likely but we fix the problem 
on Unixware 7.1.3.
 [2003-01-02 11:55 UTC] derick@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

Warnings and errors are fixed in CVS, libtool error remains:

*** Warning: inter-library dependencies are not known to be supported.
*** All declared inter-library dependencies are being dropped.

*** Warning: libtool could not satisfy all declared inter-library
*** dependencies of module libphp4.  Therefore, libtool will create
*** a static module, that should work as long as the dlopening
*** application is linked with the -dlopen flag.

 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 08:02:55 2014 UTC