php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21164 setcookie parse string parameters
Submitted: 2002-12-23 05:15 UTC Modified: 2002-12-23 05:17 UTC
From: ilya at fresenius dot ru Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.2.3 OS: FreeBSD 4.2.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ilya at fresenius dot ru
New email:
PHP Version: OS:

 

 [2002-12-23 05:15 UTC] ilya at fresenius dot ru
Setcookie autochange how least @ char  to %XX style. Example:

setcookie('Somemail', 'some@dot.com');

real cookies will looks like set to:
Somemail =  some%40dot.com

only workaround what i found - by using  header()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-23 05:17 UTC] derick@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed May 19 03:01:24 2021 UTC