php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21148 collect2 error: ar related
Submitted: 2002-12-22 15:09 UTC Modified: 2003-03-09 18:46 UTC
From: gburnore at netbasix dot net Assigned:
Status: No Feedback Package: Compile Failure
PHP Version: 4.2.3 OS: SCO Openserver 5.0.5
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-12-22 15:09 UTC] gburnore at netbasix dot net
For some reason, on OSR 5.0.5, the creation of the .a files creates a problem.  It's easily fixed each time it occurs by running:   ar -ts afilename.a  and restarting the make.

Is there a simple way to force it every time a .a file is created?  

Also, if I may, I'd like to offer login/space on an OSR5.0.5
system in case you folks need it to test/debug installs on OpenServer.

The relevant part of the error.  This may be a libtool issue.

/bin/sh /local/src/www/php-4.2.3/libtool --silent --mode=link gcc -I. -I/local/s
rc/www/php-4.2.3/ -I/local/src/www/php-4.2.3/main -I/local/src/www/php-4.2.3 -I/
local/src/www/php-4.2.3/Zend -I/local/src/www/php-4.2.3/ext/mysql/libmysql -I/lo
cal/src/www/php-4.2.3/ext/xml/expat  -I/local/src/www/php-4.2.3/TSRM -g -O2   -o
 php -export-dynamic     stub.lo libphp4.la
./.libs/libphp4.a: libelf error: elf_getarsym:
collect2: ld returned 1 exit status
make[1]: *** [php] Error 1
make[1]: Leaving directory `/local/src/www/php-4.2.3'

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-03-09 18:46 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Mar 03 18:01:32 2024 UTC