php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21088 Pspell breaks connecting to mysql using localhost
Submitted: 2002-12-18 19:22 UTC Modified: 2003-01-02 18:52 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mark at seventhcycle dot net Assigned:
Status: No Feedback Package: Pspell related
PHP Version: 4.3.0RC3 OS: Linux 2.4
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-12-18 19:22 UTC] mark at seventhcycle dot net
Here is my configure line:

./configure --with-mysql=/usr/local/mysql \
--with-pspell \
--with-xml \
--with-apxs2=/usr/local/apache2/bin/apxs \
--enable-track-vars \
--with-gd \
--with-freetype-dir=/usr \
--enable-gd-native-ttf \
--enable-gd-imgstrttf \
--with-jpeg-dir=/usr \
--with-png-dir=/usr \
--with-zlib

The perpetrating line is :

mysql_connect("localhost", "root", "xxxxx");

// this is NOT my server password

On the other hand if I change the line to:

mysql_connect("66.139.73.7", "root", "xxxxx");

The error message is:

Warning: mysql_connect() [function.mysql-connect]: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /home/melwakil/web/QueryClass.php on line 9


After doing a make distclean and reinstalling php without with-pspell on the command line, it connects fine.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-18 19:25 UTC] mark at seventhcycle dot net
// Where it says:


On the other hand if I change the line to:
mysql_connect("66.139.73.7", "root", "xxxxx");
The error message is:

// it should say:

On the other hand if I change the line to:
mysql_connect("66.139.73.7", "root", "xxxxx");

I can connect to the database successfully...

The error message when using "localhost" is:

// Sorry for the mixup
 [2002-12-19 18:49 UTC] iliaa@php.net
Which version of MySQL & Pspell are you using?
 [2003-01-02 18:52 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Oct 20 09:01:23 2020 UTC