php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21021 Cant find internal referened functions within a class
Submitted: 2002-12-14 18:08 UTC Modified: 2002-12-15 03:46 UTC
From: daniel at electroteque dot org Assigned:
Status: Not a bug Package: Class/Object related
PHP Version: 4.3.0RC3 OS: Redhat 8
Private report: No CVE-ID: None
 [2002-12-14 18:08 UTC] daniel at electroteque dot org
Since i have upgraded my entire class script is buggered up.

Call to undefined function: _crypt()

here is the snippets

function login($username,$password,$remember,$page){
$this->db = $GLOBALS['db'];
$this->password = $this->_crypt($password);
$this->_check_username($username);
$this->_check_password($username);
$this->_is_confirmed($username);

if ($this->username_result && $this->pass_result && $this->confirmed_result){
$this->_setSession($remember,true);
	redirect($page);
//return true;
	}
else
	// login/pass check failed
	{
	$this->logout($_SERVER['PHP_SELF'].$this->_build_errorquery($this->result));
	}
  }

//pass password :: private
function _crypt($password){
	return md5($password);
}


i cant honestly see what the reason for this is, i suggest its a bug , as my script was working before , what is even more wierd , my function was called _encrypt it wasnt working so i changed it to _crypt and it started working fine , i have reloaded my page today and its back to the same error.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-14 18:14 UTC] derick@php.net
Please trim down your code to the smallest possible script that shows the problem AND can be easily copied and pasted for us to test.

Derick
 [2002-12-14 18:37 UTC] daniel at electroteque dot org
class auth {
function login($username,$password){
$this->db = $GLOBALS['db'];
echo $this->password = $this->_crypt($password);
}

//pass password :: private
function _crypt($password){
	return md5($password);
}

}


use:

auth::login("dan","bollox");
 [2002-12-14 18:46 UTC] daniel at electroteque dot org
bugger for some reason the :: reference doesnt work anymore, it was previously

i tried $auth = new auth();

$auth->login();

and it was ok , i suppose its a me error :)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 27 03:03:34 2021 UTC