php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #21016 php_w32api functions undefined
Submitted: 2002-12-14 13:02 UTC Modified: 2002-12-14 13:06 UTC
From: info at frenck dot nl Assigned:
Status: Not a bug Package: *Extensibility Functions
PHP Version: 4.3.0RC3 OS: Windows 2000
Private report: No CVE-ID: None
 [2002-12-14 13:02 UTC] info at frenck dot nl
I've installed PHP4.3.0RC3 (altough, all 4.3.0 releases have te same problem).

I've set the php.ini file for use with the w32api extension.

But, it seem not to load the extension correctly.

The phpinfo() shows it is loaded:

Win32 API Support Enabled

But when I call one of the functions of the w32api, than I get a undefined function error.

This produces an undefined function error:
w32api_register_function ("User32.dll", "MessageBoxA", "long");

I've printed a function list with get_defined_functions(). An found none of the w32api functions.

I've even tried to load it trough dl() and tried it with apache 1.3.20 (sapi module), but the problem remains. 

After installing 4.2.2 again, everything work fine again.

Seem to me that there is something wrong there...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-14 13:07 UTC] derick@php.net
The API of this experimental extension has changed. Not a bug -> bogus.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 18 22:01:22 2020 UTC