php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20934 htmlspecialchars returns latin1 from UTF-8
Submitted: 2002-12-11 06:58 UTC Modified: 2002-12-12 07:38 UTC
From: renato at cria dot org dot br Assigned:
Status: Closed Package: Strings related
PHP Version: 4CVS-2002-12-11 (dev) OS: Red hat linux 8.0
Private report: No CVE-ID:
 [2002-12-11 06:58 UTC] renato at cria dot org dot br

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-12 07:10 UTC] moriyoshi@php.net
Thanks for your effort again.
Verified this behaviour.

 [2002-12-12 07:19 UTC] wez@php.net
Is this problem also in the PHP 4.3.0RC3?
If so, this should be resolved before release.
 [2002-12-12 07:38 UTC] moriyoshi@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.

It's fortunate that I managed to fix this before the release.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 16 13:02:46 2014 UTC