php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20901 Query to MySQL hangs for 90sec from Netscape 4.08
Submitted: 2002-12-09 06:04 UTC Modified: 2002-12-09 09:33 UTC
From: judd at ob-wan dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 4.2.3 OS: Win2K Server
Private report: No CVE-ID: None
 [2002-12-09 06:04 UTC] judd at ob-wan dot com
Querying MySQL takes an awfully long time from Netscape. I am running 4.08 and cannot comment about other versions. IE 5.5 does not display this problem.

A clue to debugging this is that changing focus after the query brings the result back immediately.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-09 06:21 UTC] msopacua@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


AFAIK, no browser is able to access MySQL, so some example code would be pleasant.
 [2002-12-09 07:43 UTC] judd at ob-wan dot com
Try this one, it really takes ages:

function verify_login($username, $password) {
/* verify the username and password.  if it is a valid login, return an array
 * with the username, firstname, lastname, and email address of the user */

 	$qid = db_query("
	SELECT username, firstname, lastname, email, priv
	FROM users
	WHERE username = '$username' AND password = '" . md5($password) . "'
	");

	return db_fetch_array($qid);
}
 [2002-12-09 07:49 UTC] sniper@php.net
That script is really useless to us.
And FYI, the used browser has ABSOLUTELY NOTHING to do with
how long PHP runs some script. Bogus.

 [2002-12-09 08:20 UTC] judd at ob-wan dot com
Sniper,

It can, and it does. If you hadn't been in such a hurry to discount the zipfile I sent you, many of these problems would now be dust. Evidently everything is useless to you.

Less haste, more speed.
 [2002-12-09 08:26 UTC] sniper@php.net
This stays bogus as long as you're unable to provide us a SHORT and SELF-CONTAINED script that clearly shows the error.
 [2002-12-09 09:33 UTC] msopacua@php.net
Judd,

in general:
please read and comply with the instructions mentioned in 'How to report'. Saying "I'm seeing this.." doesn't help us, unless you're going to buy tickets and have us fly over.

The reason that an example script should be self-contained, is quite simple:
we're not going to invest time into figuring out where $foo, which isn't there in the example script possibly came from.

Example scripts should be short, simply, because:
1) Long scripts don't fit in here well
2) It shows that you've taken adequate steps to identify if this IS a bug, or an error in your own scripting.

The bug database is for resolving bugs in PHP, not your own scripts or scripts/packages you've downloaded.

Bug #20906 is yet again a clear example and this will create a negative bias against you. The attitude doesn't help either.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Mar 31 11:01:25 2020 UTC