|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20896 php -w hangs indefinitely at 100% CPU
Submitted: 2002-12-09 00:03 UTC Modified: 2003-08-12 20:30 UTC
Avg. Score:4.0 ± 0.7
Reproduced:4 of 4 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (25.0%)
From: carl at thep dot lu dot se Assigned:
Status: Closed Package: CGI/CLI related
PHP Version: 4.3.3RC2-dev OS: SuSE 7.2
Private report: No CVE-ID:
 [2002-12-09 00:03 UTC] carl at thep dot lu dot se
Not quite a crash, but I found no better category (time to add one for
the CLI SAPI?)
A simple
php -w filename.php
will on my system output the things it should, but then hang forever at
full CPU consumption.

[PHP Modules]


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-11 02:20 UTC] ljpersson at hotmail dot com
Also repeatable on SuSE 8.0
 [2002-12-11 02:38 UTC]
This happens also with the -s option. And with CGI binary too. Basically the reason is that the -s / -w options use some hackish way to accomplish the tasks. Which seems to work on some systems though..

 [2002-12-13 05:46 UTC] ljpersson at hotmail dot com
Same problem exists in 4.3.0RC3
 [2002-12-22 12:19 UTC] andrew at evilwalrus dot com
Works fine for me on WinXP SP1 with 4.4.0-dev (CVS).
 [2003-01-07 14:31 UTC] internet at choq dot fm
I have a similar problem on Slackware 8.1, on a kernel 2.4.20.

PHP version 4.3 Release.

When I start the server everything is fine for a little while. After a bit the CPU load increases dramatically and dosn't stop. Top shows me that the httpd processes are in a infinite loop. Also I can'T kill them at all, even with a kill -HUP.

uptime : 
15:28:55 up 18:21,  3 users,  load average: 47.15, 46.94, 44.35

with 46 looped httpd process.

I removed all the php scripts on the server and everything runs fine afdterwards, so it's definately caused by php.

I will recompile PHP and apache later tonight to see if this might be a problem between the kernel/apache/php4.

I will try posting more info as well. I know that mysql, gd, freetype, zlib, libpng, libjpeg are installed but I don't remmeber the others.
 [2003-01-08 16:59 UTC] sthomas at townnews dot com
This bug also affects PHP 4.3.0 Final, at least on Redhat 7.3 and Redhat 8.0. Pretty odd to have 100% cpu usage when it's already finished with the whitespace stripping or syntax hilighting.
 [2003-08-12 20:30 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Thu Oct 08 23:01:31 2015 UTC