php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20864 Cc/Bcc fields don't seem to work
Submitted: 2002-12-06 11:13 UTC Modified: 2003-01-13 14:41 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: blueroom at digitalmente dot net Assigned:
Status: Closed Package: Mail related
PHP Version: 4.2.3 OS: Windows 2000
Private report: No CVE-ID: None
 [2002-12-06 11:13 UTC] blueroom at digitalmente dot net
Adding a header to an e-mail stating "Cc: something@some.com" makes mail() return a Server error. "Bcc: something" seems to work, but the e-mail copy never gets sent.

Tried two SMTP servers, one on Windows 2000 (i think it was IMailSrv or something like that), and normal sendmail on a linux machine. Sendmail returned an error for Bcc as well.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-06 11:14 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2002-12-06 12:32 UTC] blueroom at digitalmente dot net
I'm having a hard time getting that CVS build to work (using IIS) ... I'm using it as a CGI binary and it always returns the "PHP CGI cannot be accessed directly blabla" page. Here are my php.ini CGI options:

cgi.force_redirect = 0;
cgi.redirect_status_env = ;
fastcgi.impersonate = 1;
cgi.rfc2616_headers = 1;

I've tried mapping the .php extension to both php.exe and php-cgi.exe. Mapping it to php-cgi.exe seems to make the request for any script hang around forever.

By the way, it would be nice if the CVS Windows builds didn't have Unix linebreaks on the text/ini files :)
 [2002-12-06 12:35 UTC] blueroom at digitalmente dot net
Addendum to last comment: php-cgi.exe does not make the request hang forever. Sorry about that. All the other info still stands.
 [2002-12-06 18:31 UTC] sniper@php.net
So does the mail work now?

 [2002-12-07 02:55 UTC] cg at gordimer dot net
In my case, Cc: and Bcc: work now (dev and stable snapshots on winXP).

Christoph
 [2002-12-07 10:10 UTC] blueroom at digitalmente dot net
I seem to have been misunderstood. I tried using the referred devel snapshot and I always get the "PHP CGI cannot
be accessed directly [...]" message, even with the parameters shown above. Can anybody tell me what else might be wrong (note: I haven't had these problems with any other PHP release before..)
 [2002-12-08 02:39 UTC] sniper@php.net
Are you sure your php.ini is even read? Is it in correct place? Is it with correct NAME..(common problem, people tend to name it php.ini.ini on Windows)

 [2002-12-24 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over 2 weeks, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-01-13 14:41 UTC] blueroom at digitalmente dot net
PHP 4.3.0 so far seems to have solved this issue, that's why I posted no further feedback. Sorry for not closing the bug sooner
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Jul 23 19:01:25 2021 UTC