php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20858 dba_open create always a lock file
Submitted: 2002-12-06 08:57 UTC Modified: 2002-12-09 23:14 UTC
From: csollet at coleebris dot com Assigned: helly (profile)
Status: Not a bug Package: DBM/DBA related
PHP Version: 4.3.0RC2 OS: Linux 2.2.16
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: csollet at coleebris dot com
New email:
PHP Version: OS:

 

 [2002-12-06 08:57 UTC] csollet at coleebris dot com
Already reported in comment on #20828. I make a separate bug report since it's another bug.

Opening a db with <? dba_open("E.db", "r", "db2"); ?>
create a lock file (note that the "l" attribute is not used)
This script will fail on a ro directory!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-12-07 09:11 UTC] helly@php.net
This was intended and the documentation is bad on this. 'l' and 'd' are only to force one of the two.

Maybe i'll add a new modifier to skip locking...
 [2002-12-09 12:08 UTC] helly@php.net
I added '-' modifier for that now. And marked this one duplicate. See bug 20828 for more.
 [2002-12-09 23:14 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Dec 01 15:01:34 2020 UTC