php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #2085 After full installation, when restarting, apache does not work properly
Submitted: 1999-08-17 09:19 UTC Modified: 1999-08-17 13:45 UTC
From: agm19 at tid dot es Assigned:
Status: Closed Package: Dynamic loading
PHP Version: 3.0.12 OS: Linux version 2.0.36 (root@porky
Private report: No CVE-ID: None
 [1999-08-17 09:19 UTC] agm19 at tid dot es
After following all the instructions to install php3-0-12, I added
the "new" lines into apache's httpd.conf configuration file.
Afterall, "httpd" binary dows not run properly, hangs and stop.
Maybe the "AddModule/LoadModule" lines should keep an order
in the configuration file. These are mine:

LoadModule env_module         libexec/mod_env.so
LoadModule config_log_module  libexec/mod_log_config.so
LoadModule mime_module        libexec/mod_mime.so
LoadModule negotiation_module libexec/mod_negotiation.so
LoadModule status_module      libexec/mod_status.so
LoadModule info_module        libexec/mod_info.so
LoadModule includes_module    libexec/mod_include.so
LoadModule autoindex_module   libexec/mod_autoindex.so
LoadModule dir_module         libexec/mod_dir.so
LoadModule cgi_module         libexec/mod_cgi.so
LoadModule asis_module        libexec/mod_asis.so
LoadModule imap_module        libexec/mod_imap.so
LoadModule action_module      libexec/mod_actions.so
LoadModule userdir_module     libexec/mod_userdir.so
LoadModule alias_module       libexec/mod_alias.so
LoadModule rewrite_module     libexec/mod_rewrite.so
LoadModule access_module      libexec/mod_access.so
LoadModule auth_module        libexec/mod_auth.so
LoadModule anon_auth_module   libexec/mod_auth_anon.so
LoadModule digest_module      libexec/mod_digest.so
LoadModule headers_module     libexec/mod_headers.so
LoadModule setenvif_module    libexec/mod_setenvif.so
LoadModule perl_module        libexec/libperl.so
# LoadModule php3_module        libexec/libphp3.so
LoadModule jserv_module       libexec/libjserv.so
LoadModule php_module         libexec/mod_php.so

and the same for AddModule's list.

Any comments?

Thanks in advance.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-08-17 13:45 UTC] sas at cvs dot php dot net
No comment, but a suggestion. Please follow http://bugs.php.net/bugs-dos-and-donts.php3 and resubmit a bug report.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Oct 19 21:01:24 2020 UTC