php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20672 cybercash_encr() not found
Submitted: 2002-11-27 06:43 UTC Modified: 2002-11-27 07:17 UTC
From: mark at seventhcycle dot net Assigned:
Status: Not a bug Package: *E-commerce functions
PHP Version: 4.3.0RC1 OS: Linux
Private report: No CVE-ID: None
 [2002-11-27 06:43 UTC] mark at seventhcycle dot net
Configure Line:

'./configure' '--with-mysql=/usr/local/mysql' '--with-cybercash=/usr/www/www-utils/mck-3.3.1-i586-pc-linux-gnulibc2.1' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--prefix=/usr' '--with-config-file-path=/etc' '--enable-track-vars' '--enable-trans-sid' '--with-mysql=/usr' '--with-apxs=/usr/sbin/apxs' '--with-gd' '--with-freetype-dir=/usr' '--enable-gd-native-ttf' '--enable-gd-imgstrttf' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--with-zlib' 

The Code:

    function CCEncrypt($message)
    {
        $session_key = sprintf("%s #%ld", date("D M j H:i:s Y"), getmypid());
        $enc_msg = cybercash_encr($this->merchant_key, $session_key, $message);
        $message = cybercash_base64_encode($enc_msg['outbuff']);
        $mac = cybercash_base64_encode($enc_msg['macbuff']);

        /* This adds the information needed to decrypt. */
        $encrypted_message = 'message=' . urlencode($message) . '&';
        $encrypted_message .= 'session-key=' . urlencode($session_key) . '&';
        $encrypted_message .= 'mac=' . urlencode($mac);
    
        return $encrypted_message;
    }


The Error:

Fatal error: Call to undefined function: cybercash_encr() in /usr/www/shanesworld.com/public_html/adm/class.cyberclass.inc on line 154

I have php 4.2.3 that I do a "make install" back and forth between this and 4.3.0rc1.  4.2.3 has no problem finding the function, and it is configured using the same ./configure line.

The code itself is part of CyberClass, which is available here:
http://www.zend.com/codex.php?id=115&single=1

I presume since I haven't had trouble with 4.2.3, it's something in 4.3.0.  Good luck ;)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-27 07:17 UTC] jan@php.net
I wonder where you're using this, verisign, which bought cybercash a year a go or so shut down the service in february. We nuked this extension.
 [2002-11-27 17:24 UTC] mark at seventhcycle dot net
Here is the configuration info from the file the script reads:

#######################

MCK_TYPE = 

# CyberCash Payment Service (CCPS) Host address for SSL connections
#
CCPS_SSL_HOST = https://cr.cybercash.com/cgi-bin/

# CyberCash Payment Service (CCPS) Host adress for Direct Connect CGIs
#
CCPS_HOST = http://cr.cybercash.com/cgi-bin/

# Agile Wallet Server at CyberCash
#
CCW_HOST = a.merchant.agilewallet.com

##########################

Going to agilewallet.com redirects to Verisign, I know...  But cybercash support on their end has NOT been shut down.  Perhaps they are somehow integrating this with Payflow on their end, but one way or another, the service is still up.

I'll try and call verisign to see if I can find out more from them...  But the bug/post isn't bogus.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 16:01:25 2019 UTC