php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20653 It works for a short time and then gives warning message
Submitted: 2002-11-26 11:04 UTC Modified: 2002-12-14 23:54 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: mojdeh at und dot edu Assigned:
Status: Not a bug Package: iPlanet related
PHP Version: 4.2.2 OS: solaris 8
Private report: No CVE-ID: None
 [2002-11-26 11:04 UTC] mojdeh at und dot edu
We have sunone-iplanet webserver 6.0 sp4 and php 4.2.2 on 
our solaris 8 box. the php files come up for maybe half a day and after that we get warning messages like this one:
Warning: Failed opening '/raid/www/docs/undserves/cdisplay.php' for inclusion (include_path='.:/usr/local/lib/php') in Unknown on line 0
The problem it intermittend. some time after reloding the file the warning goes away but it shows up next time we go to page.
We just upgraded iplanet 4.1 to sunone-iplanet 6.0sp4 and also our php4.0.4pl1 to php4.2.2

Is this a bug or I am missing a step? I just thought of some thing! do you think I need to delete the /usr/local/php directory before compiling and installing the new version of php?
thanks,

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-26 20:36 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-12-06 19:16 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-12-11 14:00 UTC] mojdeh at und dot edu
I upgrated my php to 4.3.0RC2. I am getting the following error message know:
failed to create stream: Too many open files in Unknown on line 0

Also the sendmail Path is not set not either. This was not a problem in older version of php (like 4.0.4pl1)

Thanks
 [2002-12-14 23:54 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

'Too many open files' error implies that the file system has run out of avaliable file handles and no new files can be opened. This is not a PHP problem, try raising your file handle limit, it'll probably resolve the issue.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Jun 25 06:01:25 2019 UTC