php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20565 This verion doesn';t supports JFIF 1.02
Submitted: 2002-11-22 04:04 UTC Modified: 2002-11-25 06:32 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: bogomil at webgate dot bg Assigned:
Status: Closed Package: GetImageSize related
PHP Version: 4.3.0RC1 OS: Linux
Private report: No CVE-ID: None
 [2002-11-22 04:04 UTC] bogomil at webgate dot bg
If image is jpg and compression is JFIF 1.02
the return value is null.
if compression is JFIF 1.0 the return value is like documentation '2'(jpg)

 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-22 05:20 UTC] bogomil at webgate dot bg
The problem now is that PHP doesn;t rekognise not the JFIF verion propertly, the problem is if in JPG file exists and EXIF header too , the returns of the function is Null
 [2002-11-22 07:12 UTC] iliaa@php.net
Could you please provide a sample image (URL), which we could use to replicate the problem.
 [2002-11-22 07:22 UTC] bogomil at webgate dot bg
http://danypow4.hit.bg/Ticket.jpg
there is URL, The file is in JPG format with JFIF compresiion v 1.02 but with exif headers.
The functions returns nothing, but file is JPG.
Firs i must check is there any EXIF headers (with exif functions)...?
 [2002-11-22 09:17 UTC] iliaa@php.net
I cannot seem to download the image at the specified URL, please email it to me (iliaa@php.net).
 [2002-11-22 09:34 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

Recieved user's image via email, both getimagesize() and exif_read_data() appear to handle the image correctly using PHP 4.3.0-dev and 4.4.0-dev.
 [2002-11-25 02:25 UTC] bogomil at webgate dot bg
With 4.3.0RC1 this function doesn't returns value for an JPG file!
 [2002-11-25 06:32 UTC] sniper@php.net
RC1 is already outdated..4.3.0-dev is more recent and seems to work.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Apr 15 10:01:23 2021 UTC