php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20486 register_tick_function crashes apache
Submitted: 2002-11-18 13:56 UTC Modified: 2003-01-02 18:39 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:2 (50.0%)
Same OS:2 (50.0%)
From: junkie at overdoos dot org Assigned:
Status: No Feedback Package: Scripting Engine problem
PHP Version: 4.4.0-dev OS: win2k
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-11-18 13:56 UTC] junkie at overdoos dot org
Register_tick_function crashes Apaches. These are the specs.

tried it on combinations of win2k with apache 1.3.22 and php as sapi
with versions 4.2.2 , 4.2.3 and 4.4.0-dev 
and tried it with apache 2.0.43 with 4.4.0-dev too

the scripts was the example code from the documentation. It worked on our cobalt server but when i wanted to use it for real when working at home it crashed apache. 

crashes an apache thread (probably) with a memory fault .. couldnt read
from address 0x0etc . server does keep running though.

when commenting //register_tick_function() it works fine. 
even leaving declare(ticks=1) {......} in tact.

Vincent.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-18 14:00 UTC] junkie at overdoos dot org
think it should be a scripting engine problem.. i dont know.. and its reproduceble...
 [2002-12-08 10:56 UTC] sniper@php.net
Must be some win32 thing as I can not reproduce this within Linux (and apache 1.3.27).

 [2002-12-19 23:08 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip


 [2003-01-02 18:39 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2005-08-10 13:14 UTC] fredrik at demomusic dot nu
This is a duplicate. Please use this bug-report for this matter: http://bugs.php.net/bug.php?id=26771
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 08:05:53 2022 UTC