php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20476 Apache cannot load libphp4.so into server. Undefined symbol IS_SLASH_P
Submitted: 2002-11-18 03:01 UTC Modified: 2002-12-04 18:16 UTC
From: dks at wl dot dn dot ua Assigned:
Status: No Feedback Package: Apache related
PHP Version: 4.4.0-dev OS: ASPLinux 7.2
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-11-18 03:01 UTC] dks at wl dot dn dot ua
I made dso module for apache 1.3.26.
And when apache starting this error appears:

[root@www root]# service httpd start
Starting httpd: Syntax error on line 261 of /etc/httpd/conf/httpd.conf:
Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: IS_SLASH_P
                                                           [ FAILED ]
But binary file php works correctly. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-18 03:12 UTC] derick@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-11-18 07:11 UTC] dks at wl dot dn dot ua
This version of php requires curl-7.10.2, but in download section of http://curl.sourceforge.net avaible only 7.10.1:=(
May be this is a mistake? Or some?
 [2002-11-18 08:48 UTC] dks at wl dot dn dot ua
So, this latest php cvs snapshot isn't working to. Message IS_SLASH_P undefined appears again. May be this is a bug...
 [2002-11-18 10:45 UTC] sniper@php.net
Exactly how did you configure PHP?
And are you sure your libphp4.so is the one that you compiled?

 [2002-11-19 03:05 UTC] dks at wl dot dn dot ua
This is my config.nice:
[root@www src]# cat config.nice
#! /bin/sh
#
# Created by configure

'./configure' \
'--with-pgsql=/usr/local/pgsql' \
'--with-zlib' \
'--with-layout=GNU' \
'--with-ssl' \
'--with-dom=/usr/local/lib' \
'--without-mysql' \
'--with-xslt-sablot' \
'--enable-xslt' \
'--with-iconv=/usr/local/lib/' \
'--with-curl=../curl-7.9.7/' \
'--with-apxs=/usr/sbin/apxs' \
'--enable-calendar' \
'--with-gettext=/bin' \
'--with-java=/usr/local/jdk1.3.1_04' \
'--with-ming=/usr/lib' \
'--with-gd' \
'--enable-gd-native-ttf' \
'--with-png-dir=/usr' \
'--with-jpeg-dir=/usr' \
'--with-freetype-dir=/usr/local' \
"$@"

And i'am sure that libphp4.so is one, i just compiled.
 [2002-11-23 16:42 UTC] iliaa@php.net
Does the php-cli (/usr/local/bin/php) work properly?
 [2002-12-04 18:16 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 04:01:24 2020 UTC