php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20433 Unaligned access error messages at runtime
Submitted: 2002-11-14 15:34 UTC Modified: 2002-11-30 12:39 UTC
From: bfischer at syslog dot ch Assigned: helly (profile)
Status: Closed Package: Compile Warning
PHP Version: 4.3.0-RC1 OS: Tru64, NetBSD(Alpha platform)
Private report: No CVE-ID: None
 [2002-11-14 15:34 UTC] bfischer at syslog dot ch
When testing cli/cgi, unaligned access messages are displayed.

Following modifications fixes problem.

in main/php_globals.h
int log_errors_max_len
changed to
long log_errors_max_len

in ext/standard/file.h
int default_socket_timeout
int auto_detect_line_endings
changed to
long default_socket_timeout
long auto_detect_line_endings

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-15 05:34 UTC] nohn@php.net
Verified with 4.3.0RC1
 [2002-11-16 10:47 UTC] nohn@php.net
Verified on NetBSD/Alpha.
 [2002-11-30 10:35 UTC] helly@php.net
The problem is OnUpdateInt which will result in an error on 64bit systems. Compiling and testing now.
 [2002-11-30 12:39 UTC] helly@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 [2002-12-10 10:26 UTC] soula at lifl dot fr
I work on ALPHA/Tru64 with the same pb as above. But I've found 4 more fix (cf. patch at the end).

Moreover, there is another source of confusion with int/long in "zend_parse_parameters()" function. The variable for token "l" should be a long and the 2nd variable for token "s" should be a int.

This patch fix (I hope) these pb :
ftp://codon.genopole-lille.fr/pub/php-4.3.0RC2-stat+onupdateint+zendparam.patch
 [2002-12-14 12:34 UTC] tom at minnesota dot com
I found the same problems on NetBSD/Alpha-1.6. The patch listed does fix the problem but apparently it hasn't made it's way into CVS as of 12/13/2002. Since this bug was closed, I reported another bug #20433. It was then marked bogus due to the problem already being reported, not fixed, but closed.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Feb 23 10:01:34 2024 UTC