php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20429 ./configure gettext error
Submitted: 2002-11-14 11:06 UTC Modified: 2002-11-26 20:05 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: henjo at glas dot its dot tudelft dot nl Assigned:
Status: Closed Package: Compile Failure
PHP Version: 4.2.3 OS: Linux 2.4.19 / Debian 3.0
Private report: No CVE-ID: None
 [2002-11-14 11:06 UTC] henjo at glas dot its dot tudelft dot nl
I'm trying to compile PHP 4.2.3 on Debian 3.0 (woody) with gettext support. When trying to ./configure --with-gettext or --with-gettext=DIR (tried all different lib/include dirs I could think of) I always get the following error:

..
checking for GNU gettext support... yes
checking for bindtextdomain in -lintl... no
checking for bindtextdomain in -lc... no
configure: error: Unable to find required gettext library

I checked the lib and include dirs and it seems like all the libraries and headers are in place.
I've also tried the latest tarball from GNU, but that gives the same result.

I can supply my entire configure list if necessary, and would be happy to try some hints you might have.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-14 11:08 UTC] iliaa@php.net
Where is your gettext installed?
 [2002-11-14 11:20 UTC] sniper@php.net
And check the config.log for more information why the checks fail. It might not be gettext related at all.

 [2002-11-14 11:45 UTC] henjo at glas dot its dot tudelft dot nl
/usr/bin/gettext
/usr/include/libintl.h
/usr/lib/libc.so

I've tried the --with-gettext=/usr but it doesn't work.
What is the configure script looking for anyway? the .so files?

This is the bottom of the config.log:
=====
int main() {
bindtextdomain()
; return 0; }
configure:25664: checking for bindtextdomain in -lc
configure:25683: gcc -o conftest -g -O2  -DLINUX=22 -DMOD_SSL=208111 -DUSE_HSREG
EX -DEAPI -DUSE_EXPAT  -Wl,-rpath,/usr/local/lib -L/usr/local/lib -L/usr/local/l
ib conftest.c -lc  -lgd -lfreetype -lpng -lz -ljpeg -lz -lcrypt -lresolv -lm -ld
l -lnsl  -lresolv -lcrypt 1>&5
/usr/local/lib/libgd.so: undefined reference to `XpmReadFileToXpmImage'
collect2: ld returned 1 exit status
configure: failed program was:
#line 25672 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char bindtextdomain();

int main() {
bindtextdomain()
; return 0; }
======
 [2002-11-26 20:05 UTC] sniper@php.net
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at http://snaps.php.net/.
 
In case this was a documentation problem, the fix will show up soon at
http://www.php.net/manual/.

In case this was a PHP.net website problem, the change will show
up on the PHP.net site and on the mirror sites in short time.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 22 08:03:41 2022 UTC