php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20413 PDF support with PDFLIB crash the apache server
Submitted: 2002-11-13 12:09 UTC Modified: 2002-11-13 12:10 UTC
From: alietss at yahoo dot com Assigned:
Status: Not a bug Package: PDF related
PHP Version: 4CVS-2002-11-13 OS: Linux RedHat 8.0
Private report: No CVE-ID: None
 [2002-11-13 12:09 UTC] alietss at yahoo dot com
Hi all the php developers, I'm testing php-4.3.0 in RedHat 8.0,httpd-2.0.40 from redhat packages, I built rpms for this plataform with pdf support with pdflib-4.0.3, here my configure...
%configure \
	--prefix=%{_prefix} \
	--with-config-file-path=%{_sysconfdir} \
	--enable-force-cgi-redirect \
	--disable-debug \
	--enable-pic \
	--disable-rpath \
	--enable-inline-optimization \
	--with-bz2 \
	--with-db3 \
	--with-curl \
	--with-dom=%{_prefix} \
	--with-exec-dir=%{_bindir} \
	--with-freetype-dir=%{_prefix} \
	--with-png-dir=%{_prefix} \
	--with-gd \
	--enable-gd-native-ttf \
	--with-ttf \
	--with-gdbm \
	--with-gettext \
	--with-pdflib=shared \
	--with-tiff-dir=%{_prefix} \
	--with-ncurses \
	--with-gmp \
	--with-iconv \
	--enable-xslt=shared \
	--with-jpeg-dir=%{_prefix} \
	--with-openssl \
	--with-png \
	--with-pspell \
	--with-regex=system \
	--with-xml \
	--with-expat-dir=%{_prefix} \
	--with-zlib \
	--with-layout=GNU \
	--enable-bcmath \
	--enable-exif \
	--enable-ftp \
	--enable-magic-quotes \
	--enable-safe-mode \
	--enable-sockets \
	--enable-sysvsem \
	--enable-sysvshm \
	--enable-discard-path \
	--enable-track-vars \
	--enable-trans-sid \
	--enable-yp \
	--enable-wddx \
	--without-oci8 \
	--with-pear=/usr/share/pear \
	--with-imap=shared \
	--with-imap-ssl \
	--with-kerberos=/usr/kerberos \
	--with-ldap=shared \
	--with-mcal=shared,%{_prefix} \
	--with-mcrypt=shared,%{_prefix} \
	--with-mhash=shared,%{_prefix} \
	--with-mysql=shared,%{_prefix} \
%if %{oracle}
	--with-oci8=shared \
%endif
	--with-pgsql=shared \
	--with-snmp=shared,%{_prefix} \
	--with-snmp=shared \
	--with-sybase-ct=shared,%{_prefix} \
	--with-xslt-sablot=shared,%{_prefix} \
	--with-sablot-js=shared,%{_prefix} \
	--enable-ucd-snmp-hack \
	--with-unixODBC=shared \
	--enable-memory-limit \
	--enable-bcmath \
	--enable-shmop \
	--enable-versioning \
	--enable-calendar \
	--enable-dbx \
	--enable-dio \
	--enable-mcal \

and when I include in my php.ini the pdflib extensions the httpd server crash and fail to start,in the past php-4.2.4-dev was ok, this is the apache log error,  
[Wed Nov 13 00:41:57 2002] [notice] caught SIGTERM, shutting down
/usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined symbol: PDF_get_majorversion
/usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined symbol: PDF_get_majorversion
/usr/sbin/httpd: relocation error: /usr/lib/php4/pdf.so: undefined symbol: PDF_get_majorversion

                                   I hope helps, bye aliet

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-13 12:10 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in PHP.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri May 24 22:01:26 2019 UTC