php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20396 Not correct URL Parsing
Submitted: 2002-11-12 10:51 UTC Modified: 2002-11-12 12:41 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: young at sl dot com dot ua Assigned:
Status: Not a bug Package: URL related
PHP Version: 4CVS-2002-11-12 OS: Linux SUSE
Private report: No CVE-ID: None
 [2002-11-12 10:51 UTC] young at sl dot com dot ua
IF i type URL test.php?a=b&11&c=d I have:
$_GET["a"] = "b";
IF i type URL test.php?a=b&11&c=d&e= I have:
$_GET["a"] = "b";
$_GET["c"] = "d";

I think that is incorrect

sorry for my english

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-12 10:58 UTC] nicos@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 [2002-11-12 11:57 UTC] derick@php.net
Nicos, of course this is a bug.

Can you tell whether the problem is gone when you compile PHP
with the --disable-mbstring option to configure?

Derick
 [2002-11-12 12:13 UTC] young at sl dot com dot ua
whhen i recompile PHP with --disable-mbstring ALL is ok. But i think that is a BUG
 [2002-11-12 12:23 UTC] derick@php.net
yup, sounds like a bug.
Can you please run "make test" after you ran "make" and answer "y" if it asks to send your info to PHP-QA? This will help us reproduce the problem.

thanks,
Derick
 [2002-11-12 12:26 UTC] young at sl dot com dot ua
I run "make test" and got
-----------------
Number of tests :  226
Tests skipped   :   96 (42.5%)
Tests failed    :   17 ( 7.5%)
Tests passed    :  113 (50.0%)
Time taken      :   24 seconds
-----------------
And it not ask me nothing.
 [2002-11-12 12:31 UTC] young at sl dot com dot ua
Something again
stock:/usr/local/src/php-4.3.0-dev-zend2-alpha2 # make test | grep FAIL
FAIL Test array_merge and array_walk (001.phpt)
FAIL Test arsort, asort, krsort, ksort, rsort, and sort (002.phpt)
FAIL Test usort, uksort and uasort (003.phpt)
FAIL Tests for floor en ceil (floorceil.phpt)
FAIL serialize()/unserialize()/var_dump() (001.phpt)
FAIL serialize() (Bug #14293) (002.phpt)
FAIL Console_Getopt (001-getopt.phpt)
FAIL PEAR constructor/destructor test (pear1.phpt)
FAIL PEAR_Autoloader (pear_autoloader.phpt)
FAIL PEAR_Config (pear_config.phpt)
FAIL PEAR_Registry (pear_registry.phpt)
FAIL System commands tests (pear_system.phpt)
FAIL Testing $argc and $argv handling (011.phpt)
FAIL Output buffering tests (006.phpt)
FAIL Regression test (023.phpt)
FAIL Looped regression test (may take a while) (024.phpt)
FAIL Internal hash position bug on assignment (Bug #16227) (031.phpt)
 [2002-11-12 12:39 UTC] young at sl dot com dot ua
Maybe this will help
------------------------

System Linux stock 2.4.18 #5 SMP Wed Jun 5 23:48:57 EEST 
2002 i686 
Build Date Nov 12 2002 19:58:26 
Configure Command './configure' '--with-mysql' '--with-apxs=/usr/sbin/apxs' '--with-zlib' '--with-xml' '--disable-mbstring' 
Server API Apache 
Virtual Directory Support disabled 
Configuration File (php.ini) Path /etc/php.ini 
API Versions: PHP: 20020307
PHP Extension: 20010927
Zend Extension: 20010710 
Debug Build no 
Thread Safety disabled 
Zend Engine v2.0.0-alpha2, Copyright (c) 1998-2002 Zend Technologies
 [2002-11-12 12:39 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.

It appears that you are NOT using the latest CVS, because for one it does come with Zend Engine 2 and the make tests offers to notify the QA team with the results.
Download the 'real' latest CVS from http://snaps.php.net/php4-STABLE-latest.tar.gz and if the problem persists (I doubt it will, I cannot replicate it using latest CVS) reopen the bug report.
 [2002-11-12 12:41 UTC] iliaa@php.net
Sorry about that, the url for latest snapshot is actually
http://snaps.php.net/php4-latest.tar.gz
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 20 06:03:37 2021 UTC