php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20370 Undefined symbol PQescapeBytea
Submitted: 2002-11-11 16:27 UTC Modified: 2002-11-11 16:31 UTC
Votes:1
Avg. Score:1.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: darkoak at syngenuity dot net Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 4CVS-2002-11-11 OS: Gentoo 2.4.19 (Linux)
Private report: No CVE-ID: None
 [2002-11-11 16:27 UTC] darkoak at syngenuity dot net
When configuring/compiling the latest stable build (2002_11_10_1739) with PostgreSQL support and as an Apache DSO (through apxs)
./configure --with-pgsql=/usr/local/pgsql --with-axps=/usr/sbin/apxs 

and using 7.2.1 of PgSQL, the symbol PQescapeBytea is undefined.

I know this is a "development" version of PHP, but in order to get everything I need running 'correctly' it is a necessity. My 'abnormal' configure line (not the one used above):

./configure --with-apxs=/usr/sbin/apxs --with-pear --with-openssl --enable-sigchild --enable-libgcc --with-zlib-dir=/usr/local/lib --with-zlib --with-jpeg-dir=/usr/local/lib --with-gd=/usr/ --with-png-dir=/usr/local/lib --with-xpm-dir --with-freetype-dir=/usr/local/lib --with-curl=shared,/usr/local --with-pgsql=/usr/local/pgsql --enable-wddx --enable-inline-optimization --enable-calendar --enable-native-ttf --enable-mbstring --without-mysql

Lib versions are:
curl: 7.10.2-pre4
freetype: 2.1.2
gd: 2.0.4 (broken in previous PHP builds)
libjpeg: 6b
libpng: 1.2.5
zlib: 1.1.4
openssl: 0.9.6g

Using Apache 1.3.20 (DSO) with psql 7.2.1 (built with: locale/recode/multibyte/debug/cassert/perl/python/java/pam/openssl/syslog)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-11 16:29 UTC] darkoak at syngenuity dot net
Nm, sorry to bother you. Found the problem. *slaps head*
 [2002-11-11 16:31 UTC] iliaa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.


 [2004-05-02 23:11 UTC] wwwAlchemist at yahoo dot com
I am having the same problem and I don't know the reason. Would you mind explaining why you slapped your head? How did you solve it?

Thanks
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 26 11:01:26 2019 UTC