php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20285 Undefined Function
Submitted: 2002-11-06 10:51 UTC Modified: 2002-11-08 08:09 UTC
From: jonathan at rietta dot com Assigned:
Status: Not a bug Package: Mail related
PHP Version: 4.2.3 OS: RedHat Linux 7.1
Private report: No CVE-ID: None
 [2002-11-06 10:51 UTC] jonathan at rietta dot com
When I try to run any script on either of my two servers (one running PHP 4.2.3 and one running a CVS build from several months ago) mail() mysteriously crashes and spits out the following error:

PHP Fatal error:  Call to undefined function:  mail() in mailtester.php on line 2

The code tripping the error is as follows:

<?php
mail("e-mail@hidden.txt", "Test", "This is a test.\nJonathan");  
echo "<html><body><p>the mail was sent</p></body></html>";
?>

This just started happening; one day everything worked fine, the next day it just quit. I'm running with Qmail and have not changed anything with my Qmail/PHP/Apache/Evironment settings. This occurs both through Apache as well as through the command line.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-07 19:06 UTC] sniper@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PHP.
 [2002-11-08 08:09 UTC] jonathan at rietta dot com
You're right. As it turns out, the bug was only existent on the 4.3.0 version of PHP, which I rebuilt a newer version of and everything was fine. Thanks.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue Nov 29 22:05:54 2022 UTC