php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20211 Segfault in sapi_apache_header_handler
Submitted: 2002-11-01 05:34 UTC Modified: 2002-11-01 10:05 UTC
From: mbr at freebsd dot org Assigned:
Status: Not a bug Package: Zlib related
PHP Version: 4CVS-2002-11-01 OS: FreeBSD
Private report: No CVE-ID: None
 [2002-11-01 05:34 UTC] mbr at freebsd dot org
#0  0x2836810e in sapi_apache_header_handler (sapi_header=0xbfbff5e4, sapi_headers=0x2853c790) at mod_php4.c:259
259                     table_set(r->headers_out, header_name, header_content);
(gdb) bt
#0  0x2836810e in sapi_apache_header_handler (sapi_header=0xbfbff5e4, sapi_headers=0x2853c790) at mod_php4.c:259
#1  0x28370f79 in sapi_add_header_ex (header_line=0x8be0a0c "Content-Encoding", header_line_len=22, duplicate=1 '\001',
    replace=1 '\001') at SAPI.c:557
#2  0x283828ac in zif_ob_gzhandler (ht=2, return_value=0x8bdb86c, this_ptr=0x0, return_value_used=1) at zlib.c:1273
#3  0x2835178e in call_user_function_ex (function_table=0x80de080, object_pp=0x0, function_name=0x8d7718c,
    retval_ptr_ptr=0xbfbff7a8, param_count=2, params=0xbfbff75c, no_separation=1, symbol_table=0x0)
    at zend_execute_API.c:532
#4  0x28376197 in php_end_ob_buffer (send_buffer=1 '\001', just_flush=0 '\000') at output.c:177
#5  0x2837652f in php_end_ob_buffers (send_buffer=1 '\001') at output.c:267
#6  0x2836b907 in php_request_shutdown (dummy=0x0) at main.c:775
#7  0x28368442 in php_apache_request_shutdown (dummy=0x0) at mod_php4.c:390
#8  0x80514f2 in run_cleanups ()
#9  0x805cd15 in make_child ()
Cannot access memory at address 0x3dc26069.

#0  0x2836810e in sapi_apache_header_handler (sapi_header=0xbfbff5e4, sapi_headers=0x2853c790) at mod_php4.c:259
259                     table_set(r->headers_out, header_name, header_content);
(gdb) list
254             if (!strcasecmp(header_name, "Content-Type")) {
255                     r->content_type = pstrdup(r->pool, header_content);
256             } else if (!strcasecmp(header_name, "Set-Cookie")) {
257                     table_add(r->headers_out, header_name, header_content);
258             } else {
259                     table_set(r->headers_out, header_name, header_content);
260             }
261
262             *p = ':';  /* a well behaved header handler shouldn't change its original arguments */
263
(gdb) p r->headers_out
Cannot access memory at address 0x84.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-11-01 05:42 UTC] mbr at freebsd dot org
Looks like this one is related to:

#19919
 [2002-11-01 10:05 UTC] sniper@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Sep 30 16:01:24 2020 UTC