php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20195 make install doesnt set permissions
Submitted: 2002-10-31 11:30 UTC Modified: 2003-07-29 08:48 UTC
Votes:4
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:1 (25.0%)
From: cycloon at linux-de dot org Assigned:
Status: Closed Package: PEAR related
PHP Version: 4.3.2 OS: linux
Private report: No CVE-ID: None
 [2002-10-31 11:30 UTC] cycloon at linux-de dot org
make install doesnt set proper permissions to the installed files. (All other programs do so). If you have set "umask 077" you'll get an unusable php installation, and for example POST-data cant be submitted in a form.

This thing caused me compiling php 20 times and loosing the whole day.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-31 12:01 UTC] sniper@php.net
Exactly what files are installed with wrong permissions??
(and how can this affect the POSTs at all? :)

 [2002-10-31 13:51 UTC] cycloon at linux-de dot org
Hardly every files are installed incorrectly, even directories are not set to 755. Normally "make install" uses "install" i think (apache does so) and they use the options -g, -m and -o to set group, mode and owner of the files, php does not, it just creates the files and this normaly uses the permission a user set with 'umask' like you create a file with touch or so.
 [2002-10-31 14:23 UTC] cycloon at linux-de dot org
POSTs are infected as the php binary is created correctly (gcc gives it the right permission) but include files and other folders have wrong permissions, so POSTs dont work.

Using the "install" programm with its arguments to set permissions, owner and group would solve this problem.
 [2003-01-03 17:37 UTC] nicos@php.net
Do you still experiment the problem with PHP 4.3.0 ?

(can you verify the permission of pear in /usr/local/bin/pear by default too? )

Thank you for your report.
 [2003-01-03 18:18 UTC] cycloon at linux-de dot org
no, i changed my umask for root back to 022, since some other apps had the same problems, but i still think, that we should use "install" to copy the files
 [2003-02-27 09:39 UTC] gpt at tirloni dot org
Hi,

 I'm having the same problem. If you want to have more details please see bug report #22454.

 Was it fixed or will it be fixed for 4.3.2?

Thanks in advance
 [2003-07-21 08:40 UTC] meebey@php.net
This happened duo a bug in PEAR 1.0, which set wrong file permissions on package installing, (/usr/local/share/pear and /usr/local/lib/php cotains PEAR packages)...
This bug was fixed in PEAR 1.1 see bug #23179.

 [2003-07-24 02:28 UTC] meebey@php.net
does this problem still exists with PEAR 1.1 and PHP 4.3.2? check the permissions in /usr/local/lib/php or /usr/local/share/pear and show me a ls -la of the directory.

 [2003-07-29 07:23 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2003-07-29 08:48 UTC] davey@php.net
Heres an ls -al on a freshly installed PEAR 1.2b:

total 116
drwxr-xr-x   15 root     root          584 Jul 19 10:37 .
drwxr-xr-x    4 root     root           96 Jul 19 10:36 ..
-rw-r--r--    1 root     root            6 Jul 19 10:37 .filemap
-rw-r--r--    1 root     root            0 Jul 19 10:37 .lock
drwxr-xr-x    2 root     root          352 Jul 19 10:37 .registry
drwxr-xr-x    2 root     root           72 Jul 19 10:37 Archive
drwxr-xr-x    2 root     root           80 Jul 19 10:37 Console
drwxr-xr-x    2 root     root          464 Jul 19 10:37 DB
-rw-r--r--    1 root     root        29165 Jul 19 10:37 DB.php
drwxr-xr-x    2 root     root          160 Jul 19 10:37 Mail
-rw-r--r--    1 root     root         7331 Jul 19 10:37 Mail.php
drwxr-xr-x    2 root     root          104 Jul 19 10:37 Net
drwxr-xr-x    2 root     root           80 Jul 19 10:37 OS
drwxr-xr-x    4 root     root          416 Jul 19 10:37 PEAR
-rw-r--r--    1 root     root        29942 Jul 19 10:37 PEAR.php
drwxr-xr-x    3 root     root          336 Jul 19 10:37 PHPUnit
-rw-r--r--    1 root     root         2355 Jul 19 10:37 PHPUnit.php
-rw-r--r--    1 root     root        14884 Jul 19 10:37 System.php
drwxr-xr-x    3 root     root          128 Jul 19 10:37 XML
drwxr-xr-x    3 root     root           72 Jul 19 10:37 data
drwxr-xr-x    4 root     root          104 Jul 19 10:37 docs
-rw-r--r--    1 root     root         9154 Jul 19 10:37 pearcmd.php
drwxr-xr-x    4 root     root          104 Jul 19 10:37 tests

Just to confirm that it is fixed in CVS
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Oct 16 22:03:34 2021 UTC