php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #20109 iplanet 6 core dump w/NSAPI load
Submitted: 2002-10-26 14:40 UTC Modified: 2003-03-13 13:00 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:5 of 5 (100.0%)
Same Version:3 (60.0%)
Same OS:4 (80.0%)
From: cjs at goosenest dot org Assigned:
Status: Closed Package: iPlanet related
PHP Version: 4.3.0 OS: Solaris 9
Private report: No CVE-ID: None
 [2002-10-26 14:40 UTC] cjs at goosenest dot org
This bug is similar to 18701 and 15439, but those bugs never reported backtraces or have been full resolved.

The ns-httpd process crashes and core dumps as follows:

26/Oct/2002:14:28:05] catastrophe (12480): Server crash detected (signal SIGBUS)
[26/Oct/2002:14:28:05] info (12480): Crash occurred in NSAPI SAF php4_execute
[26/Oct/2002:14:28:05] info (12480): Crash occurred in function php_register_variable_ex from module

when loading any php script. The php script that reproduces this is:

bash-2.05$ more phpinfo.php 
<html>
 <head>
  <title>PHP Test</title>
 </head>
 <body>
 <?php echo "Hello World<p>"; ?>
 <? phpinfo(); ?>
 </body>
</html>

Configuration info:

Running snapshot: php4-200210252100

iPlanet 6 SP4 Webserver on Solaris 9
iPlanet-WebServer-Enterprise/6.0SP4 B07/17/2002 14:04

./configure  --enable-debug --enable-libgcc --with-nsapi=/usr/iplanet/servers/

gdb backtrace:

(gdb) bt
#0  0xfe629cac in php_register_variable_ex (var=0xfe6c05a8 "REQUEST_LINE", 
    val=0xfda5f6b8, track_vars_array=0xfe6c05a8, tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210252100/main/php_variables.c:176
#1  0xfe62986c in php_register_variable_safe (var=0xfe6c05a8 "REQUEST_LINE", 
    strval=0xc722f0 "GET /phpinfo.php HTTP/1.1", str_len=25, 
    track_vars_array=0x35a6d8, tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210252100/main/php_variables.c:56
#2  0xfe629784 in php_register_variable (var=0xfe6c05a8 "REQUEST_LINE", 
    strval=0xc722f0 "GET /phpinfo.php HTTP/1.1", track_vars_array=0x35a6d8, 
    tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210252100/main/php_variables.c:37
#3  0xfe678df0 in sapi_nsapi_register_server_variables (
    track_vars_array=0x35a6d8, tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210252100/sapi/nsapi/nsapi.c:290
#4  0xfe61e794 in php_hash_environment (tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210252100/main/main.c:1220
#5  0xfe61d258 in php_request_startup (tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210252100/main/main.c:857
#6  0xfe67956c in nsapi_module_main (request_context=0xc72d60, 
    tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210252100/sapi/nsapi/nsapi.c:458
#7  0xfe679744 in php4_execute (pb=0xc3f88, sn=0xc36a48, rq=0xc36a90)
    at /home/cjs/work/php4-200210252100/sapi/nsapi/nsapi.c:523
#8  0xff1d89b4 in __0FNfunc_exec_strP6KFuncStructP6GpblockP6HSessionP6HRequest
    () from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#9  0xff1d9cf8 in INTobject_execute ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#10 0xff1dd8e8 in INTservact_service ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#11 0xff1dde84 in INTservact_handle_processed ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#12 0xff215c0c in __0fLHttpRequestUUnacceleratedRespondPCcTBPc ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#13 0xff2150c0 in __0fLHttpRequestNHandleRequestP6Gnetbuf ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#14 0xff213388 in __0fNDaemonSessionDrunv ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#15 0xff163b80 in ThreadMain ()
   from /usr/iplanet/servers/bin/https/lib/libnsprwrap.so
#16 0xfede76a0 in _pt_root ()
   from /usr/iplanet/servers/bin/https/lib/libnspr4.so

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-26 15:19 UTC] cjs at goosenest dot org
Recompiled with the latest snap (php4-200210261200) and with Forte 7 compilers (previous was with gcc 2.95.3) . Similar crash, here is the dbx backtrace:

t@18 (l@18) terminated by signal SEGV (no mapping at the fault address)
0xfd8f6834: DumpThreads+0x000c: ldub    [%o0 + 0x38], %o0
Current function is php_register_variable
   37           php_register_variable_safe(var, strval, strlen(strval), track_vars_array TSRMLS_CC);

(dbx) where
current thread: t@18
  [1] DumpThreads(0x0, 0x587040, 0x17c, 0xfdbd4de4, 0xfdb89080, 0x0), at 0xfd8f6834
  [2] panicHandler(0xfeb3e194, 0xfdc5f610, 0x2000, 0x1b852000, 0xb, 0xfdbd5000), at 0xfd9afe98
  [3] __sighndlr(0xb, 0xfdc5f610, 0xfdc5f358, 0xfd9ae7a0, 0x0, 0x0), at 0xfebb60a0
  [4] call_user_handler(0xb, 0xfdc5f610, 0xfdc5f358, 0x0, 0x0, 0x0), at 0xfebafdd8
  [5] sigacthandler(0xb, 0xfdc5f610, 0xfdc5f358, 0x7efefeff, 0x81010100, 0xfdc5ec88), at 0xfebaff88
  ---- called from signal handler with signal 11 (SIGSEGV) ------
  [6] strlen(0x0, 0x0, 0x36c, 0x7efefeff, 0x81010100, 0xfdc5ec88), at 0xfeab2ea8
=>[7] php_register_variable(var = 0xfe3e1b94 "SERVER_NAME", strval = (nil), track_vars_array = 0x35a6d8, tsrm_ls = 0x1792d8), line 37 in "php_variables.c"
  [8] sapi_nsapi_register_server_variables(track_vars_array = 0x35a6d8, tsrm_ls = 0x1792d8), line 321 in "nsapi.c"
  [9] php_register_server_variables(tsrm_ls = 0x1792d8), line 1220 in "main.c"
  [10] php_hash_environment(tsrm_ls = 0x1792d8), line 1320 in "main.c"
  [11] php_request_startup(tsrm_ls = 0x1792d8), line 857 in "main.c"
  [12] nsapi_module_main(request_context = 0xc72d60, tsrm_ls = 0x1792d8), line 458 in "nsapi.c"
  [13] php4_execute(pb = 0xc3f88, sn = 0xc36a48, rq = 0xc36a90), line 523 in "nsapi.c"
  [14] func_exec_str(0x2f0d4c, 0xc3f88, 0xc36a48, 0xc36a90, 0x0, 0x0), at 0xff1d89ac
  [15] INTobject_execute(0x60448, 0xc36a48, 0xc36a90, 0x0, 0xff2ced3c, 0x2f0d4c), at 0xff1d9cf0
  [16] INTservact_service(0xc36a48, 0xc36a90, 0x0, 0x4, 0x40, 0x290470), at 0xff1dd8e0
  [17] INTservact_handle_processed(0xc36a48, 0xc36a90, 0x2, 0x290470, 0xfffffffc, 0xc727a8), at 0xff1dde7c
  [18] HttpRequest::UnacceleratedRespond(0xc36998, 0xc720e0, 0x0, 0xc72100, 0xc721a8, 0x0), at 0xff215c04
  [19] HttpRequest::HandleRequest(0xc36998, 0xc70058, 0xc720e0, 0xc720d0, 0x2000, 0xc700b8), at 0xff2150b8
  [20] DaemonSession::run(0xc39f70, 0x2000, 0xff2b3d78, 0xff214a9c, 0x0, 0xff2cc2f4), at 0xff213380
  [21] ThreadMain(0xc39f70, 0xff163b3c, 0x17828, 0x0, 0x0, 0x0), at 0xff163b78
  [22] _pt_root(0xd1308, 0xfee01074, 0x1, 0x0, 0x0, 0x0), at 0xfede7698
 [2002-10-26 17:01 UTC] iliaa@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip

I've just commited a patch to the CVS that may address the problem you are seeing.
 [2002-10-27 08:49 UTC] cjs at goosenest dot org
Tried php4-200210262100, same crash, same backtrace.

Crash:
[27/Oct/2002:09:45:07] catastrophe (29972): Server crash detected (signal SIGBUS)
[27/Oct/2002:09:45:07] info (29972): Crash occurred in NSAPI SAF php4_execute
[27/Oct/2002:09:45:07] info (29972): Crash occurred in function php_register_variable_ex from module /usr/iplanet/servers/bin/libphp4.so
[27/Oct/2002:09:45:12] failure (29957): Child process admin thread is shutting down

Backtrace:
#0  0xfe629ccc in php_register_variable_ex (var=0xfe6c05c0 "REQUEST_LINE", 
    val=0xfda5f6b8, track_vars_array=0xfe6c05c0, tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210262100/main/php_variables.c:176
#1  0xfe62988c in php_register_variable_safe (var=0xfe6c05c0 "REQUEST_LINE", 
    strval=0xc722f0 "GET /phpinfo.php HTTP/1.1", str_len=25, 
    track_vars_array=0x35a6d8, tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210262100/main/php_variables.c:56
#2  0xfe6297a4 in php_register_variable (var=0xfe6c05c0 "REQUEST_LINE", 
    strval=0xc722f0 "GET /phpinfo.php HTTP/1.1", track_vars_array=0x35a6d8, 
    tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210262100/main/php_variables.c:37
#3  0xfe678e10 in sapi_nsapi_register_server_variables (
    track_vars_array=0x35a6d8, tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210262100/sapi/nsapi/nsapi.c:290
#4  0xfe61e7b4 in php_hash_environment (tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210262100/main/main.c:1220
#5  0xfe61d278 in php_request_startup (tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210262100/main/main.c:857
#6  0xfe679590 in nsapi_module_main (request_context=0xc72d60, 
    tsrm_ls=0x1792d8)
    at /home/cjs/work/php4-200210262100/sapi/nsapi/nsapi.c:460
#7  0xfe679768 in php4_execute (pb=0xc3f88, sn=0xc36a48, rq=0xc36a90)
    at /home/cjs/work/php4-200210262100/sapi/nsapi/nsapi.c:525
#8  0xff1d89b4 in __0FNfunc_exec_strP6KFuncStructP6GpblockP6HSessionP6HRequest
    () from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#9  0xff1d9cf8 in INTobject_execute ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#10 0xff1dd8e8 in INTservact_service ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#11 0xff1dde84 in INTservact_handle_processed ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#12 0xff215c0c in __0fLHttpRequestUUnacceleratedRespondPCcTBPc ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#13 0xff2150c0 in __0fLHttpRequestNHandleRequestP6Gnetbuf ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#14 0xff213388 in __0fNDaemonSessionDrunv ()
   from /usr/iplanet/servers/bin/https/lib/libns-httpd40.so
#15 0xff163b80 in ThreadMain ()
   from /usr/iplanet/servers/bin/https/lib/libnsprwrap.so
#16 0xfede76a0 in _pt_root ()
   from /usr/iplanet/servers/bin/https/lib/libnspr4.so
 [2002-11-02 14:11 UTC] kalowsky@php.net
As much as I don't like nsapi, we can't have it not working for 4.3.0 release... since it has historically worked (sometimes).
 [2002-11-16 13:09 UTC] cjs at goosenest dot org
Updated to iPlanet-WebServer-Enterprise/6.0SP5 and tried 
php4-STABLE-200211161630. Same crash, no change.


[16/Nov/2002:14:07:33] catastrophe (22765): Server crash detected (signal SIGBUS)
[16/Nov/2002:14:07:33] info (22765): Crash occurred in NSAPI SAF php4_execute
[16/Nov/2002:14:07:33] info (22765): Crash occurred in function php_register_variable_ex from module /usr/iplanet/servers/bin/libphp4.so
 [2002-11-21 22:57 UTC] cjs at goosenest dot org
Added 4.3.0-dev to version.
 [2003-01-02 16:52 UTC] cjs at goosenest dot org
Tested and reverified with 4.3.0 release.
 [2003-03-13 13:00 UTC] thetaphi@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-STABLE-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-STABLE-latest.zip

NSAPI register_server_variables completely redesigned. Should work now.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Apr 14 19:01:28 2024 UTC