php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19964 Fix for bug 19482 missing from latest snapshot
Submitted: 2002-10-17 15:32 UTC Modified: 2002-10-17 17:03 UTC
From: speedfreak50 at netscape dot net Assigned:
Status: Not a bug Package: PCRE related
PHP Version: 4CVS-2002-10-17 OS: Red Hat 7.3
Private report: No CVE-ID: None
 [2002-10-17 15:32 UTC] speedfreak50 at netscape dot net
Bugfix for #19482 against php-4.2.3 fixed the segfaults but I had to upgrade our PHP to 4.2.4dev because bug #19829 was nailing us.
After upgrade, the segfaults reappeared.  Checking latest version from snaps.php.net (200210171200) i noticed the fix for #19482 has disappeared from php_pcre.c

Wondering if this was intentional or not.  If not intential i will attempt to generate a backtrace of the more recent segfault.

For now i have re-patched the php4-STABLE-200210171200.tar.gz  version with the fix from 19482.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-17 17:03 UTC] sniper@php.net
It was fixed in the non-stable branch. 
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 14:03:18 2021 UTC