php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19958 lisablot.so.96: libsablot.so.96: Undefined symbol "__pure_virtual"
Submitted: 2002-10-17 11:15 UTC Modified: 2002-12-11 13:43 UTC
From: online at sys4tec dot com Assigned:
Status: Not a bug Package: XSLT related
PHP Version: 4.2.3 OS: FreeBSD 4.2-RC1
Private report: No CVE-ID: None
 [2002-10-17 11:15 UTC] online at sys4tec dot com
Hi!

Problem for building Expat+Sablotron with PHP and Apache.

My configuration: 
FreeBSD 4.2-RC1

apache_1.3.27 

./configure --enable-module=rewrite --prefix=/usr/local/apache --enable-module=so

libiconv-1.8
./configure ?prefix=/usr/local/libiconv

expat-1.95.5
./configure ?prefix=/usr/local/expat

make buildlib                                                    make installlib

Sablot-0.96 with Sablot-0.96.1.patch
./configure --prefix=/usr/local/sablot \
--with-expat-prefix=/usr/local/expat --with-iconv-prefix=/usr/local/libiconv

php-4.2.3

rm config.cache                                                ./configure \                                                           --with-mysql --with-apxs=/usr/local/apache/bin/apxs --with-zlib --enable-wddx \                                                     
--with-iconv=/usr/local/libiconv --with-iconv-dir=/usr/local/libiconv \                                                           --with-expat-dir=/usr/local/expat --with-xslt --with-xslt-sablot=/usr/local/sablot

For this config examples for test xslt-sablot not working. I get messages like this:

------------------------------------------------------------Fatal error: Call to undefined function: xslt_create() in /wwwroot/home/xslt_transform/class.xslt.php on line 82

IF I add to this config key --enable-xslt, when re-starting web-server I get message like this:

Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:

Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/sablot/lib/libsablot.so.96: Undefined symbol "__pure_virtual"

/usr/local/apache/bin/apachectl start: httpd could not be started

Who know how solve this problem, please?

regards,
  Sergei

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-17 12:32 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip
 [2002-10-26 12:08 UTC] msopacua@php.net
Did the snapshot fix the problem?
If not, can you paste the final line of the compilation process for php - especially if -lstdc++ is in there?

recategorized
 [2002-11-10 18:22 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-11-11 03:00 UTC] online at sys4tec dot com
Hi!
I'm build PHP Version 4.3.0-dev. Finally I get same results. Now, I'm solve problem by build PHP as CGI application. Working fine! But configuration as apache-module still actual.

My phpinfo:
==========================================================
System  FreeBSD stweb.intranet 4.2-RC1 FreeBSD 4.2-RC1 #0: Wed Nov 8 i386  
Build Date  Oct 21 2002 09:36:08  
Configure Command  './configure' '--enable-force-cgi-redirect' '--enable-user-dir' '--with-mysql' '--with-zlib' '--enable-wddx' '--with-iconv=/usr/local/libiconv' '--with-iconv-dir=/usr/local/libiconv' '--with-xml' '--with-expat-dir=/usr/local/expat' '--enable-xslt' '--with-xslt-sablot=/usr/local/sablot'  
Server API  CGI  
Virtual Directory Support  disabled  
Configuration File (php.ini) Path  /usr/local/lib/php.ini  
PHP API  20020307  
PHP Extension  20020429  
Zend Extension  20021010  
Debug Build  no  
Thread Safety  disabled  
Registered PHP Streams  php, http, ftp, compress.zlib  

........
xslt
XSLT support  enabled  
Backend  Sablotron  
Sablotron Version  0.96  


xml
XML Support  active  
XML Namespace Support  active  
EXPAT Version  expat_1.95.5  
........
==========================================================

regards,
  Sergei
 [2002-12-11 13:43 UTC] msopacua@php.net
I cannot conclude otherwise, that this is a problem with libtool. You're also running an RC of an OS, that is already at 4.7 (and upgrading to that version, solves a lot of problems, not only in the gcc area).

IIC - this is - if anything - a libtool problem - not a php problem.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Nov 17 19:01:35 2019 UTC