php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1993 Startup failure of liphp3.so
Submitted: 1999-08-07 18:28 UTC Modified: 2002-06-16 08:35 UTC
From: thomas at webtrio dot de Assigned:
Status: Not a bug Package: Dynamic loading
PHP Version: 3.0.12 OS: Linux i386 (SuSE 6.0)
Private report: No CVE-ID: None
 [1999-08-07 18:28 UTC] thomas at webtrio dot de
I compiled PHP3 3.0.12 with the following options:

./configure --with-shared-apache=../apache_1.3.6 \
            --with-gd=/usr \
            --with-sybase=/usr/local/sybase \
            --with-mysql=/usr/local \
            --with-dbase=yes \
            --with-pdflib=/usr/local/include \
            --with-zlib=/usr/local \
            --with-ttf=/usr/local \
            --with-xml=/usr/local/xmlwf \
            --with-config-file=/usr/local/php \
            --with-safe-mode=yes \
            --with-track-var=yes \
            --with-magic-quotes=yes \
            --enable-t1lib=yes \
            --disable-display-source \
            --enable-memory-limit=yes \
            --enable-safe-mode=yes

Then make; make install

Because of the trouble with the '-Wl,-rpath' parameters I patched the file ../apache_1.3.6/src/modules/php3/libphp3.module:

Name: php3_module
ConfigStart
	RULE_WANTHSREGEX=yes
	CFLAGS="$CFLAGS -Wl,-rpath,/usr/local/lib -Wl,-rpath,/usr/local/lib/mysql"
	LIBS="-ldbf -lpcre -L/usr/local/lib -lz -lm -ldl -lcrypt -lnsl -lresolv -ldmalloc $LIBS -lgdbm -L/usr/lib -lgd -L/usr/local/lib -lttf -lt1 -L/usr/local/lib/mysql -lmysqlclient -lexpat -lmcrypt -lmhash"
ConfigEnd

========================

Running the Apache configure script withEXTRA_LIBS=-lbind SSL_BASE=/usr/local/ssl ./configure \
            --prefix=/usr/local/apache \
            --enable-module=ssl \
            --enable-shared=ssl \
            --activate-module=src/modules/frontpage/mod_frontpage.o \
            --enable-shared=frontpage \
            --activate-module=src/modules/perl/libperl.a \
            --enable-shared=perl \
            --activate-module=src/modules/jserv/mod_jserv \
            --enable-shared=jserv \
            --activate-module=src/modules/php3/libphp3.a \
            --enable-shared=php3 \
            --enable-module=unique_id \
            --enable-shared=unique_id \
            --enable-module=rewrite \
            --enable-shared=rewrite \
            --enable-module=auth_dbm \
            --enable-shared=auth_dbm \
            --enable-module=auth_db \
            --enable-shared=auth_db \
            --enable-module=digest \
            --enable-shared=digest \
            --enable-module=headers \
            --enable-shared=headers \
            --enable-module=expires \
            --enable-shared=expires \
            --enable-module=info \
            --enable-shared=info \
            --enable-module=log_agent \
            --enable-shared=log_agent \
            --enable-module=log_referer \
            --enable-shared=log_referer \
            --enable-module=usertrack \
            --enable-shared=usertrack \
            --enable-module=so \
            --enable-suexec \
            --suexec-uidmin=500

and compiling with make; make install generates some warnings but it works then. But when I add the lines

LoadModule php3_module        libexec/libphp3.so

and

AddModule mod_php3.c


Apache fails to start:

Cannot load /usr/local/apache/libexec/libphp3.so into server: /usr/local/apache/libexec/libphp3.so: undefined symbol: dbversion

/usr/local/apache/bin/apachectl startssl: httpd could not be started

If I uncomment the both lines for the PHP3 module, all works perfectly.

Kind regards
  Thomas Adamek

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-16 08:35 UTC] sander@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately, PHP 3 is no longer supported. Please download
the latest version of PHP 4 from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Sep 22 09:01:23 2020 UTC