php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19909 No PCRE support for mbstring
Submitted: 2002-10-14 14:48 UTC Modified: 2006-02-17 00:24 UTC
From: paul at honeylocust dot com Assigned:
Status: Not a bug Package: mbstring related
PHP Version: 4.3.0-pre1 OS: any
Private report: No CVE-ID: None
 [2002-10-14 14:48 UTC] paul at honeylocust dot com
Mbstring doesn't provide support for PCRE.  This is unfortunate since there is (experimental) UTF-8 support in PCRE which is as simple to turn on as flipping a compile flag and specifying an option to pcre_compile()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-14 16:22 UTC] wez@php.net
Since when has PCRE been a multibyte string encoding?
Can you be more specific about what you need?

PHP ships with UTF-8 enabled PCRE by default (if you
use the bundled PCRE), and has done since before 4.2
for unix (4.2 and later for windows).

mbstring != PCRE; their functions are completely different.
 [2002-11-10 18:20 UTC] sniper@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2006-02-17 00:24 UTC] hirokawa@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 19:03:37 2021 UTC