php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19901 Cannot use ssl functions of java within php
Submitted: 2002-10-14 09:38 UTC Modified: 2002-12-27 10:36 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: umut at kakalak dot org Assigned:
Status: Closed Package: Java related
PHP Version: 4.2.3 OS: Linux Redhat 7.1
Private report: No CVE-ID: None
 [2002-10-14 09:38 UTC] umut at kakalak dot org
I have a class which make use of basic ssl functions under java. I am running this class from console and everything works fine. Connection with my bank is established and transaction is completed.

I do the same things under php. Create a java object and run the needed functions. Everything runs until the connection phase. Whenever I want to connect to my bank server with ssl, function returns following error:

java.net.SocketException: Default SSL context init failed: Algorithm SunX509 not available 

Running code and error can be seen at
http://www.denizweb.net/testjava.php
http://www.denizweb.net/testjava.phps

phpinfo can be seen at
http://www.denizweb.net/phpinfo.php

a copy of my ini file can be seen at
http://www.denizweb.net/php.ini

Apache 1.3.26 statically linked.

Note that, these links will remain until someone finds a solution.

P.S.: The source code of class is not public and my Bank refuses revealing the source code. But they say that, the class is general and should run perfectly on any tcp/ip and java enabled system. They are also working on the problem and sent me many small classes to find the problem. We are focused on connection part, because php & java integration works without any problems.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-14 09:45 UTC] umut at kakalak dot org
Address of php.ini is updated as follows:

http://www.denizweb.net/php.ini.txt
 [2002-12-27 10:36 UTC] umut at kakalak dot org
Problem solved easily...
It's a problem with configuration.

I removed the following line from php.ini

java.home = /usr/java/j2sdk1.4.0_02

Somewhere in php.net, someone says that line should be. Well, I think this line makes java vm to search libraries only under this directory. After deleting it, it used its setup defaults (I guess) and it worked perfectly.

Thanx.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 00:03:49 2021 UTC