php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #199 No override option for GD in configure
Submitted: 1998-03-26 00:17 UTC Modified: 1998-03-26 00:22 UTC
From: david at uws dot edu dot au Assigned: rasmus (profile)
Status: Closed Package: Installation problem
PHP Version: 3.0b6 OS: Debian/GNU Linux 1.3
Private report: No CVE-ID: None
 [1998-03-26 00:17 UTC] david at uws dot edu dot au
During the run of "configure", the presence of the graphics
library "GD" is checked automatically - if not found,
support is not included (so it doesn't appear in the
build-defs.h file).

The problem is that if the GD library exists in a non-standard
place, there is no override option on the command-line to
"configure" for checking for the library elsewhere!  :-(

Unfortunately I don't know any autoconf syntax to be able to
supply a diff with an arg added for locating GD elsewhere.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-03-26 00:22 UTC] rasmus
Straight from the FAQ:

When I run configure, it says that it can't find the include files or library for gdbm (or some other package)! 
           You can make the configure script looks for header files and libraries in non-standard locations by specifying 
           additional flags to pass to  the C preprocessor and linker, such as: 

                       CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure
                              
           If you're using a csh-variant for your login shell (why?), it would be: 

                       env CPPFLAGS=-I/path/to/include LDFLAGS=-L/path/to/library ./configure
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 10:03:34 2021 UTC