php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19864 getimagesize slow on large file
Submitted: 2002-10-11 08:34 UTC Modified: 2002-10-11 11:35 UTC
From: Xuefer at 21cn dot com Assigned:
Status: Closed Package: GetImageSize related
PHP Version: 4.2.3 OS: linux
Private report: No CVE-ID: None
 [2002-10-11 08:34 UTC] Xuefer at 21cn dot com
getimagesize very slow on large _local_ file
for 4mb file, it take 1sec or more time!

i wonder why it's such slow to just read file head info
is it trying to buffer the whole file?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-11 08:59 UTC] sniper@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-10-11 10:18 UTC] Xuefer at 21cn dot com
system: redhat7.2

what i did:
sanning directories, get all image size to store into database

what i wanted to happend:
scan so many files in 10 seconds

what actually happened:
some of the files take about 11 seconds for each.

url of 2 sample files
http://ul.oursky.net/117549/qiumi1.jpg
http://ul.oursky.net/117549/2002100718.jpg

download to local drive before testing

almost every file take about 11 seconds
 [2002-10-11 10:23 UTC] sniper@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php4-latest.tar.gz
 
For Windows:
 
  http://snaps.php.net/win32/php4-win32-latest.zip

I can't reproduce anything like this with latest CVS..

 [2002-10-11 11:35 UTC] Xuefer at 21cn dot com
well, it's ok for the lastest snapshot
thx

closing :)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 16 00:01:23 2021 UTC