php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19800 DOM XML does not resolve entities
Submitted: 2002-10-07 09:01 UTC Modified: 2002-10-07 09:02 UTC
From: anton at fedosin dot ru Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 4.2.3 OS: linux
Private report: No CVE-ID: None
 [2002-10-07 09:01 UTC] anton at fedosin dot ru
l10n.xml:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE l:i18n SYSTEM "l10n.dtd" [
	<!ENTITY ru SYSTEM "ru.xml">
	<!ENTITY en SYSTEM "en.xml">
]>
<l:i18n xmlns:l="http://docbook.sourceforge.net/xmlns/l10n/1.0">
&ru;
&en;
</l:i18n>

l10n.xsl:

<xsl:param name="l10n.xml" select="document('../l10n/l10n.xml')"/>

<xsl:template match="/">
<xsl:copy-of select="$l10n.xml"/>
</xsl:template>

If execute l10n.xsl it just prints contents of l10n.xml without resolving &ru; and &en; entities.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-07 09:02 UTC] derick@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the original bug instead.

Thank you for your interest in PHP.
 [2002-10-07 09:02 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 09 16:01:24 2019 UTC