|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19787 Can not load module
Submitted: 2002-10-06 16:30 UTC Modified: 2002-10-06 17:45 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: matt at unix4all dot serveftp dot com Assigned:
Status: Wont fix Package: Apache2 related
PHP Version: 4.2.3 OS: FreeBSD 4.5
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-10-06 16:30 UTC] matt at unix4all dot serveftp dot com
I have a pretty serious problem with php and apache. I 
configured apache like the following:
./configure --prefix=/wwwserv2 --enable-modssl 
--with-ssl=/usr/local/ssl --enable-cgi --enable-so
then i did a 
make install
then I tested apache at this point to see if it worked and 
it works fine after the initial installation. Then I 
untared php-4.2.3 and configured it like the following:
./configure --with-apxs2=/wwwserv2/bin/apxs
then i did a 
make install
after this got done, I tried to start apache with 
/wwwserv2/bin/apachectl start and I got the following error

alphatest# /wwwserv2/bin/apachectl start
Syntax error on line 230 of /wwwserv2/conf/httpd.conf:
Cannot load /wwwserv2/modules/ into server: 
/wwwserv2/modules/ Undefined symbol 
If it changes anything this freebsd box is a digital with a 
alpha processor. I hope you can repair this problem.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-06 17:45 UTC]
PHP 4.2.x does not really support Apache 2.  It's sort of hit and miss.  Not sure why you would use Apache2 on FreeBSD as Apache2 doesn't support threading on that platform.  I strongly suggest sticking with Apache1.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Apr 24 10:01:31 2024 UTC