php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19779 pspell causes mod_cgi not work
Submitted: 2002-10-06 10:09 UTC Modified: 2002-10-06 12:03 UTC
From: raven at drehmoment dot org Assigned:
Status: Not a bug Package: *Web Server problem
PHP Version: 4.2.3 OS: debian potato i386
Private report: No CVE-ID: None
 [2002-10-06 10:09 UTC] raven at drehmoment dot org
hi,

i use php as an apache module. if i compile --with-pspell my perl cgi-bins are not working (i got 500 - internal errors, the log says "premature end of script headers") this error occurs also in php 4.2.3.
my configure options are ./configure --with-apxs=/usr/bin/apxs --with-pspell.
without pspell cgis working fine.

Greetings, Thomas.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-10-06 10:22 UTC] sander@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-10-06 11:03 UTC] raven at drehmoment dot org
i want to use pspell functions in php. so i installed pspell & aspell, compiled php with "./configure --with-apxs=/usr/bin/apxs --with-pspell". now the pspell functions work, but my mod_cgi not longer (i use php as apache module). if i run the apache with pspell compiled php, a call to an url /cgi-bin/test.pl gives me an internal error in the browser. the apache error log says:
[Sun Oct  6 16:19:18 2002] [error] [client 80.135.xxx.xxx] Premature end of script headers: /var/www/cgi-bin/test.pl

where test.pl just contains:
#!/usr/bin/perl
print "Content-type: text/html\n\n";
print "hello\n";

if i compile without pspell ("./configure --with-apxs=/usr/bin/apxs") the call returns "hello" as expected.
i have reproduced this bug with php 4.1.2 & 4.2.3. the apache version is 1.3.9
 [2002-10-06 12:03 UTC] msopacua@php.net
Is there any specific reason, you need Apache 1.3.9? It is quite old and has known vulnerabilities.
There has also been at least one API change, since then, which could very well be the problem.

Please try it with a current version of Apache.

Additionally - this bug report does not exclude the possibility that it's __any__ external module, loaded by php, that's the cause of this issue. Try some other module, that depends on an external shared lib, like gettext or iconv.

If you can do the above and still have the same problems, open it back up.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Apr 17 09:01:24 2021 UTC