php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19624 win2k/odbc/networked drives
Submitted: 2002-09-26 15:15 UTC Modified: 2002-09-26 16:15 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: tracer at netrox dot net Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 4.2.3 OS: win2k
Private report: No CVE-ID: None
 [2002-09-26 15:15 UTC] tracer at netrox dot net
Apache 1.3/PHP 4.2.2/Win2k(prof) SP3

PHP will not open tables via odbc on MAPPED drives or NETWORKED drives

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-26 15:16 UTC] derick@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-09-26 15:21 UTC] tracer at netrox dot net
If the data is on a local drive the php returns the querry correctly.  If the data is on the networked drive F: then php returns 

Warning: SQL error: [FairCom][FairCom ODBC Driver][FairCom File Library]No such table or object., SQL state S0002 in SQLExecDirect in 

Here is the pertinent PHP info
(NOT: I am using FAIRCOM drivers to acess c-tree created db's www.faircom.com)
<?
odbc_dsn = "rx30";
$odbc_userid = "";
$odbc_password = "";

$connection = odbc_connect($odbc_dsn, $odbc_userid, $odbc_password);

$query = "SELECT patient.NameLast, patient.NameFirst, patient.NameMiddle, patient.Patnbr, patient.EmpLink, patient.DOB, patient.LicNbr 
	 FROM patient
	 WHERE patient.NameLast LIKE '$ulastname%'
	 AND patient.NameFirst LIKE '$ufirstname%'"; 

$result = odbc_exec($connection, $query);

?>
 [2002-09-26 15:52 UTC] kalowsky@php.net
I'm tempted to say this isn't a PHP bug but a Faircom bug.  As ODBC doesn't care about local FS issues, its concern is mapping DSN's to data sources.  From that error you've pointed to it sounds like the Faircom drivers are not noticing it.  There is nothing that PHP can do about this.  

Marking as bogus unless you can prove otherwise.
 [2002-09-26 16:00 UTC] tracer at netrox dot net
FOUND A FIX
If apache is running as service, the above will not work, run it in a dos window under the user thats currently logged in, and it will....Go figure.  Guess it's an apache prob
 [2002-09-26 16:15 UTC] kalowsky@php.net
Not a bug -> bogus.
 [2012-11-12 22:33 UTC] salathe@php.net
Automatic comment from SVN on behalf of salathe
Revision: http://svn.php.net/viewvc/?view=revision&amp;revision=328330
Log: escaping for the database was done wrong in the past in PHP but this part of the manual still is in the past and does not reflect that change

--
Provided by anonymous #19624 (hanskrentel@yahoo.de)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon May 23 17:05:45 2022 UTC