|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19595 Functions handling with GD2 file format do not exist
Submitted: 2002-09-25 09:29 UTC Modified: 2002-09-27 08:38 UTC
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: stepan dot rybar at taskforce dot cz Assigned:
Status: Closed Package: GD related
PHP Version: 4.2.3 OS: Microsoft Windows XP (NT 5.1) EN
Private report: No CVE-ID:
 [2002-09-25 09:29 UTC] stepan dot rybar at taskforce dot cz
Although imagecreatefromgd, imagecreatefromgd2 and imagegd2 was announced as addition to some 4.x version, they do not exist in 4.2.3. I tried it with enabling php_gd.dll or php_gd2.dll in php.ini, but with no success. Calling function function_exists() with above image functions as parameter resulted in FALSE. 



Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-25 09:42 UTC]
You need to enable php_gd2.dll. For information on how to do that, ask support on the appropriate mailinglists.
 [2002-09-25 09:50 UTC] stepan dot rybar at taskforce dot cz
I have done it in disabling php_gd.dll (adding ;) in front of this line and added line php_gd2.dll in php.ini (as I wrote in my bug report). Because I can not compile PHP from source code, I have no idea what else I can do. 

Anyway, I am going to ask someone somewhere for help how to enable php_gd2.dll on Win in binary distribution.

 [2002-09-25 10:39 UTC]
Hm... seems to be a bug after all...
It seems that, for some reason, HAVE_GD_GD2 is not defined in the windows build. Can someone look into this?
 [2002-09-27 04:12 UTC] stepan dot rybar at taskforce dot cz
Just for the info: I downloaded and installed PHP 4.3.0 dev build (snapshot.log Fri Sep 27 08:00:00 2002 CET Starting snapshot 200209270600) and the problem (no support for handling with GD2 format in php_gd2.dll) in Win binary distribution still exists. I just tried if change was made and no changelog record was made. 

 [2002-09-27 08:38 UTC]
This bug has been fixed in CVS.

In case this was a PHP problem, snapshots of the sources are packaged
every three hours; this change will be in the next snapshot. You can
grab the snapshot at
In case this was a documentation problem, the fix will show up soon at

In case this was a website problem, the change will show
up on the site and on the mirror sites in short time.
Thank you for the report, and for helping us make PHP better.

 [2003-06-03 19:50 UTC] webmaster at vnn dot vn
Server : Apache 1.32
PHP  4.3.2
OS : Win XP Pro
i can't load GD2 extension php_gd2.dll in PHP , when i start Apache , it always alert "Can't load dynamic library php_gd2.dll" . I'm sure that no problems in my config . When i use file php_gd2.dll (from php 4.3.0 package) then it has no errors !!!
 [2003-06-16 02:21 UTC] freeman_rodrigues at rediffmail dot com
I require some help to install gd library on windows based computer. i  have php.4.3.0. (Install from installer file).
 Now i want to work with image functions. 
where can i get 	php_gd2.dll	file?

How do i install it?

How can i check whether it is working?

if you have the file php_gd2.dll, 
please  give me the url from where i can download it.
If you mail me via attachment, i would be obliged.

Looking forward  for your help.

With Regards
Freeman Rodrigues
 [2004-02-26 15:41 UTC] as at assd dot com
Here you can download php_gd2.dll:
 [2004-07-19 15:18 UTC] muthukumar at eventurers dot com
i want the file php_gd2.dll
 [2004-09-25 09:17 UTC] info at f-c dot ru
Use the Denwer suit which includes the PHP4 compiled with GD and a valid version of php_gd2.dll :

When You get the .exe file, You have 2 possible ways of what to do further:

1. If You don't have a webserver software installed -- launch it (it is a self-extratable zip archive bundled with Perl-written install script for Windows) and it will install the complete Denwer suite which contains Apache/Win, PHP4, Perl, MySQL, ans so on. The whole thing is very well configured and in most cases it self-installs without any problem. The only problem You may probably get -- the included docs are in russian.

2. If You already have a webserver software installed (which was my case) You may extract the archive using the 7-zip extractor: . Then use the extensions from the usr/local/php/extensions dir. The file php_gd2.dll bundled with Denwer works fine with php 4.3.x (tested with 4.3.9).
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Sat Oct 10 03:01:30 2015 UTC