php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19590 PHP4.2.3/4.2.4-dev ISAPI fails with Apache2.0.42
Submitted: 2002-09-25 07:39 UTC Modified: 2002-09-25 09:45 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: Kristian dot Bergmann at nvg dot org Assigned: edink (profile)
Status: Closed Package: Apache2 related
PHP Version: 4.2.3 OS: Windows XP
Private report: No CVE-ID: None
 [2002-09-25 07:39 UTC] Kristian dot Bergmann at nvg dot org
With the release of Apache2.0.42 I went ahead and upgraded. I wasn't all that suprised that PHP4.2.3 ISAPI failed to load with it. I got the following error:

bin\Apache.exe -f conf\httpd2.conf -t
Apache.exe: module "c:\php4build\snap\sapi\apache2filter\sapi_apache2.c" is not
compatible with this version of Apache (found 20020628, need 20020903).
Please contact the vendor for the correct version.

However, when I tried the latest stable dev-build (200209251031) the problem still persisted. It's not vital since CGI still works, but something you'll want to correct.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-25 09:28 UTC] edink@php.net
The next snapshot will contain php4apache2.dll that works with Apache 2.0.42.
 [2002-09-25 09:38 UTC] x86zman at bigfoot dot c dot o dot m dot no dot spam
I hope the 4.3.0-dev will get this update too, aye ?
 [2002-09-25 09:45 UTC] edink@php.net
Yes, both 4.2.4-dev and 4.3.0-dev snapshots will be updated.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 08 16:05:52 2022 UTC