php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19518 First four characters of form output cut off in 4.2.3
Submitted: 2002-09-20 04:06 UTC Modified: 2002-09-20 07:42 UTC
From: erica@php.net Assigned:
Status: Closed Package: mbstring related
PHP Version: 4.2.3 OS: Sun Cobalt RaQ 550 (Linux)
Private report: No CVE-ID: None
 [2002-09-20 04:06 UTC] erica@php.net
I'm making a PHP package for the RaQ550. I started with PHP 4.2.3 source and am using checkinstall to make an RPM.

PHP cuts off the first four characters of form submissions. I believe this is a bug with my specific configuration. This bug is reproducible with register_globals both on and off.

Here is my phpinfo(): http://server3.simpli.biz/info.php

Here's a test where you can enter form field information. 
http://server3.simpli.biz/form_field_test.php 
(Source: http://server3.simpli.biz/form_field_test.phps -- "view source" to see it properly)

Notice that I'm posting the raw post data as well, so you can see that all of the characters do get passed properly to PHP.

I'm using the php.ini-recommended with register_globals turned on for testing purposes. Help would be greatly appreciated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-20 05:31 UTC] wez@php.net
Don't configure using --enable-mbstr-enc-trans.
Search the bug db/php-dev list for more background.
 [2002-09-20 05:58 UTC] erica@php.net
Oi. What a nasty bug. I went ahead and voted for the other submission.

So what now? Downgrade to 4.2.2? I'm reluctant to implement the fix suggested because it hasn't been approved by the PHP developers. What are your thoughts?
 [2002-09-20 05:59 UTC] erica@php.net
Oh, forgot to mention that I do need mbstring functions in there, because I do have Japanese clients, and I am going to be distributing the package to several others who will probably need it as well.
 [2002-09-20 07:39 UTC] wez@php.net
Just don't use mbstr-enc-trans; it has been broken for a couple of releases, and that chances are very high that none of your users will ever think of using it.
Do you understand what it is supposed to do?

This has been fixed in the 4.2 branch and in head.
 [2002-09-20 07:42 UTC] wez@php.net
I missed your comment about Japanese clients.
You could roll your own package from the 4.2 branch in CVS,
although it's probably worth waiting to see about the file_exists bug before you distribute it; we might release a 4.2.4 yet -> ask on php-dev.

This PR is closed because the bug has been identified and fixed.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Nov 28 21:03:16 2021 UTC