php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19484 HTTP_POST_VARS empty
Submitted: 2002-09-18 16:54 UTC Modified: 2002-09-18 17:11 UTC
From: sweeks at kymeradesign dot com Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.2.3 OS: Windows XP pro
Private report: No CVE-ID: None
 [2002-09-18 16:54 UTC] sweeks at kymeradesign dot com
I've seen this bug reported before in here. just wanted to say that it's present in 4.2.3 

<form action="no_vars.php">
<input type="text" name="foo" value="bar">
<input type="submit">
</form>

then on the page no_vars.php

var_dump($HTTP_POST_VARS);

gives this output:

array(0) { } 


in other reports post worked when enctype="multipart/form-data" was removed. no luck on this, I've tried it both ways.

thanks for your time.
-Scott

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-18 17:08 UTC] jan@php.net
not setting method="post" makes browsers using the get method.
also please add new information for old bugreports to the old bugreports instead of opening new ones. That makes it easier for us to keep track of one particular bug.

Thank you for you interest in PHP!

 [2002-09-18 17:11 UTC] sweeks at kymeradesign dot com
I forgot to write that line in there I actually do have method="post" in the <form> tag
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Aug 02 21:01:24 2021 UTC