php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #19438 ldap_get_entries() does strlower() on attribute names
Submitted: 2002-09-16 12:20 UTC Modified: 2022-04-07 14:06 UTC
Votes:11
Avg. Score:4.2 ± 1.0
Reproduced:8 of 9 (88.9%)
Same Version:7 (87.5%)
Same OS:5 (62.5%)
From: titus dot anderson at louisville dot edu Assigned: ilutov (profile)
Status: Closed Package: LDAP related
PHP Version: 7.1 OS: *
Private report: No CVE-ID: None
 [2002-09-16 12:20 UTC] titus dot anderson at louisville dot edu
The function ldap_get_entries strlower's attribute names before returning the array of results.  ldap_get_attributes, on the other hand, does not.  It seems to me that these two functions should treat attribute names in a consistent manner.  Perhaps it would make sense to add a configuration option to allow the user to decide how attribute names should be treated.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2003-06-29 21:36 UTC] iliaa@php.net
Not a bug, feature request.
 [2010-12-03 18:13 UTC] jani@php.net
-Package: Feature/Change Request +Package: LDAP related
 [2017-01-09 06:59 UTC] heiglandreas@php.net
-PHP Version: 5,6 (PHP_5_2, PHP_5_3, HEAD) +PHP Version: 7.1
 [2017-10-23 01:19 UTC] kalle@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: mcmic
 [2017-10-23 01:19 UTC] kalle@php.net
The only way this can be introduced is with a new additional parameter to ldap_get_entries() as it would otherwise introduce a BC break.

Assigning to maintainer so he can clarify whether this should be something or not
 [2022-04-07 14:06 UTC] ilutov@php.net
-Status: Assigned +Status: Closed -Assigned To: mcmic +Assigned To: ilutov
 [2022-04-07 14:06 UTC] ilutov@php.net
As mentioned, this would be a BC break. There's no clear migration path without introducing a new function either. So I'm closing this issue. If the need for this persists a new issue can be created on GitHub.
 [2022-04-07 14:06 UTC] ilutov@php.net
As mentioned, this would be a BC break. There's no clear migration path without introducing a new function either. So I'm closing this issue. If the need for this persists a new issue can be created on GitHub.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun May 22 23:03:39 2022 UTC