php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19426 allow_url_fopen is stated to work as On/Off on php.ini
Submitted: 2002-09-16 02:03 UTC Modified: 2002-09-16 06:56 UTC
From: carenas at chasqui dot lared dot net dot pe Assigned:
Status: Not a bug Package: PHP options/info functions
PHP Version: 4.2.3 OS:
Private report: No CVE-ID:
 [2002-09-16 02:03 UTC] carenas at chasqui dot lared dot net dot pe
even if php.ini states that this variable is allowed to be "On" or "Off", there seems to be a different number of possible values (all of them turning the use of this feature off unless the value is "On").

the problem is that on a phpinfo() call later the value is stated as "no value" if it is "Off" and taking that this value is supposed to be "On" on default (like when there is no such configuration on php.ini) it is misleading.

the reason why it is shown as "no value" when there is an "Off" value is suspicious, as there is a "no value" clause also when the parameter is missing alltogether for the configuration file, eventhough the behaviour is different (if the value is Off the option is disabled, if the parameter is missing the option is disabled, both showing "no value" on a phpinfo call tough), sadly i couldn't get to the offending code on the phpinfo implementation.

also, as phpinfo shows whatever the value is set on php.ini there could be another posible problem that would need more investigation (like setting up the variable on a per directory basis to a wrong value using .htaccess if that is allowed).

not more testing was done to check if the problem could be on the functions that read the configuration file and therefore more generic than in this specific case.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-16 02:28 UTC] spic@php.net
Reclassified this as an PHP options bug.

Ain't it?
 [2002-09-16 06:56 UTC] sniper@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 18:01:55 2014 UTC