php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19337 can not link php_xmlrpc.dll to php
Submitted: 2002-09-10 10:17 UTC Modified: 2002-10-09 21:19 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: yuegong at grow-easy dot com Assigned:
Status: Not a bug Package: XMLRPC-EPI related
PHP Version: 4.2.3 OS: win2000
Private report: No CVE-ID: None
 [2002-09-10 10:17 UTC] yuegong at grow-easy dot com
I use PHP in cgi mode, when I add 
"extension=php_xmlrpc.dll"
into php.ini, 
the web page displayed 
"PHP Warning: Unable to load dynamic library 'd:\php/php_xmlrpc.dll' - ?Ҳ???ָ????ģ?顣 in Unknown on line 0 ".
but other dlls were runing ok.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-10 16:58 UTC] edink@php.net
You have probably forgotten to copy files from the dlls folder of the php distribution into your c:\winnt\system32 folder. If doing that does not solve your problem, please reopen this bug report.

 [2002-09-10 20:45 UTC] yuegong at grow-easy dot com
I have set extension_dir=d:\php in php.ini, and php_xmlrpc.dll has been copied to this folder, but the problem is still.
 [2002-09-10 20:46 UTC] yuegong at grow-easy dot com
And, I also copied the dll to d:/winnt/system32 folder.
 [2002-09-10 22:15 UTC] sniper@php.net
You have either not replaced php4ts.dll (all those!) in your system with the one found in the new release and/or you haven't moved the bundled dlls to some path in the libpath..

http://www.php.net/manual/en/install.windows.php#install.windows.extensions 

(unfortunately xmlrpc is not mentioned in the list..and I'm not sure if it really relies on any extra dlls)

 [2002-09-10 23:16 UTC] yuegong at grow-easy dot com
I have checked all php4ts.dll in my computer, there was only one copy of this file which is created in 2002-09-06(ymd), and I copied this file to d:\winnt\system32 for test, but no change had happened.
 [2002-10-09 21:19 UTC] sterling@php.net
bugs.php.net != support.php.net
 [2004-07-05 17:38 UTC] phpbugreporting at spoonydunappa dot com
I have the same problem and i argee with the comments of yuegong. I get the same results on both Windows XP and 2000. A quick search on Google shows that others are experiencing the same problem. I suggest that this is a real bug and not one to be brushed off so curtly.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Dec 03 01:03:42 2021 UTC