php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19310 can't open a file on remote server
Submitted: 2002-09-09 07:13 UTC Modified: 2002-09-09 11:16 UTC
From: rose dot gao at specialreserve dot net Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.2.1 OS: FreeBSD4.4
Private report: No CVE-ID: None
 [2002-09-09 07:13 UTC] rose dot gao at specialreserve dot net
I have just built a new web servers to replace old ones. They are running
FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell and
pdf libs). They seem to be fine in testing but when they go live we get
intermitant faults. At random times (roughly every 4-5 refreshes) one of
the includes on the page gives up the error "php_hostconnect: connect
failed". This only happens when we include files over a http:// connection
and not when we include directly. We have tried using both host names and
IP addresses and neither seem to help. Any ideas?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-09 07:19 UTC] cynic@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

 [2002-09-09 08:10 UTC] rose dot gao at specialreserve dot net
I have just built a new web servers to replace old one. They are running FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell and pdf libs).The old one was Linux machine.
When I include file with http, 
e.g include(http: //www.php.net/folder/file.include)

there is an error : "php_hostconnect: connect failed".

This happens at random times(roughly every 4-4 refreshes) and  only happens when we include files with "http"
 [2002-09-09 08:14 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 [2002-09-09 08:25 UTC] rose dot gao at specialreserve dot net
I have just built a new web servers to replace old one. They are running
FreeBSD 4.4 with Apache 1.3 and PHP 4.2.1 (compiled with mysql, pspell
and pdf libs).The old one was Linux machine.
When I include file with http, 
e.g include(http: //www.php.net/folder/file.include)

there is an error : "php_hostconnect: connect failed".

This happens at random times(roughly every 4-4 refreshes) and  only
happens when we include files with "http"
 [2002-09-09 10:40 UTC] sniper@php.net
You're still referring to 4.2.1...so which version is it?
Check from phpinfo() output..and are you sure it's not something wrong with the included file? ie. maybe there is
some network problem at the time?

 [2002-09-09 11:11 UTC] rose dot gao at specialreserve dot net
Yes, I am still using 4.2.1 version. I used 4.2.3 in the bug report in order to make somebody reply me.
I am quite sure that there was no network problem because I have tested several times. And also the included file has no problem because when I included it without "http" it worked well.
Is the 4.2.1 version has always this problem? Do you believe the new version has fixed this problem?
Thank you.
 [2002-09-09 11:16 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Please don't fool around. It really doesn't help us or you if you fake the version. And I do believe this is fixed in 4.2.3..

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Aug 01 07:01:25 2021 UTC