php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #19282 Place php4ts.dll into \sapi
Submitted: 2002-09-07 11:29 UTC Modified: 2002-09-07 11:33 UTC
Votes:3
Avg. Score:4.7 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (100.0%)
From: timo dot nentwig at web dot de Assigned:
Status: Wont fix Package: *Configuration Issues
PHP Version: 4.2.3 OS: XP Pro
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2002-09-07 11:29 UTC] timo dot nentwig at web dot de
It's not really a bug but I would like to suggest you to put php4ts.dll not only in the root directory where it is required by PHP.exe but also into \sapi for Apache2. I configured Apache2 to look for php4apach2.dll in \sapi (just where it is by default) but Apache2 won't look for php4ts.dll in the root directory but only in \sapi and %SystemRoot% directories.

So if php4ts.dll would be in PHP's root _and_ in \sapi I could easily install new PHP version: uncompress and that's it. So, I always have also to manually copy php4ts.dll to \sapi.

Just a suggestion...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-09-07 11:30 UTC] timo dot nentwig at web dot de
Changed email address.
 [2002-09-07 11:33 UTC] derick@php.net
We're not going to put in the dll twice, as it would increase download size, and it's totally unneeded.

Derick
 [2002-10-17 07:00 UTC] brunofr at ioda dot net
A simple tricky truc on win32
simply use always the same php directory
and add c:\php_dir\;c:\php_dir\dlls;c:\php_dir\extensions in your path.
don't forget to reboot ( system path refresh need it )
and you 'll never have to put dll on the windows system.

With this you can make a apache account under with your server and php scripting engine exist without the need to run under system account.

Please don't never have multiple instance of the same dll.
This would be made WindoZe more crazy than it is yet.
 [2003-12-17 20:42 UTC] dclifton61 at yahoo dot com
You could at least make note of it in the install.txt file. I spent several wasted hours trying to figure out what the problem was and the solution took about 3 seconds.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed May 22 08:01:26 2019 UTC